The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 04-19-2011, 12:39 AM
Purpose in The Hub's Avatar
Purpose in The Hub is offline
Junior Member
 
Join Date: Apr 2011
Posts: 8
Wink

Code striped out in Joomla 1.6


In case this hasn't been covered here, I was having problems with Rocket Theme templates and Joomla 1.6.

Every time i placed the script code into an article or module, it was stripping half the code out when I'd save it.

Others on RT forum having same issue.

Solution is: Article Manager > Options > Text Filtering, I selected "No Filtering" for Super Administrators or whatever user you are.

Then u can copy and paste ecwid code into J1.6 custom modules and articles.
  #2  
Old 04-25-2011, 06:15 PM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Thank you for sharing this information.

The newest Joomla 1.6 introduced a (somewhat questionable) security limitation - the JavaScript in the authored publications is removed upon saving, which in particular prohibits to use Ecwid's embed codes. The above action allows to disable this limitation to some particular group of users. Previous version of Joomla, the 1.5, did not have such limitation and does not require this setting.

Thank you for pointing out this trick.
  #3  
Old 07-01-2011, 11:18 PM
Kashmere Konnection's Avatar
Kashmere Konnection Kashmere Konnection is offline
Junior Member
 
Join Date: Jun 2011
Posts: 23
Default

Hi Eugene,
Despite setting it to No Filter for the superuser I am not able to save the code in article using toggle editor. Is there anything else that I need to do in addition to this change.
Thanks,
Bhupinder
  #4  
Old 07-02-2011, 11:18 PM
lakesentrance's Avatar
lakesentrance lakesentrance is offline
Junior Member
 
Join Date: Mar 2011
Posts: 23
Default

Barora, have you set in Global Config to use "No Editor?" . I would try that.

And make sure u'r logging in as a super user.

Then if that fails, I love using the RocketTheme Rokpad Editor (I believe it's a free extension downloadable from their website).

I use it on about 20 joomla sites, and never ever have any issues pasteing code into it. (except J1.6).

Good luck
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:14 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.