Reply
 
Thread Tools Display Modes
  #1  
Old 03-02-2017, 02:22 AM
Ladystrange's Avatar
Ladystrange is offline
 
Join Date: Jun 2010
Posts: 42
Default

404 ? disappearing products, sitemaps -not working correctly


So if you start on my front page - you can click through to a product page. Once you are on the product page and you click refresh- you get the oops that page cant be found. Also if you take the url and copy paste it in a new tab -you get the same error. Most of the links in my sitemap also points to the oops page. I have the newest wordpress, with the newest akismet , the newest yoast, and the newest ecwid installed and that is it. I tried deactivating the other 2 plug ins and the problem remained with just ecwid installed. I need the idiots guide to fixing this issue please, thank you
Reply With Quote
  #2  
Old 03-02-2017, 01:58 PM
Stacy_P's Avatar
Stacy_P Stacy_P is offline
Ecwid Team
 
Join Date: Jan 2016
Posts: 283
Default

Quote:
Originally Posted by Ladystrange View Post
So if you start on my front page - you can click through to a product page. Once you are on the product page and you click refresh- you get the oops that page cant be found. Also if you take the url and copy paste it in a new tab -you get the same error. Most of the links in my sitemap also points to the oops page. I have the newest wordpress, with the newest akismet , the newest yoast, and the newest ecwid installed and that is it. I tried deactivating the other 2 plug ins and the problem remained with just ecwid installed. I need the idiots guide to fixing this issue please, thank you
Hello,

This is Stacy from Ecwid Customer Care Team.

Thank you very much for contacting us on this matter!

I'm sorry you faced this problem with your Ecwid store. Please, no worries, we are here and ready to help you!

We are aware of the problem already. It was reported to the development team and they're currently looking into it. I'll keep you posted and get back to you once there's any news on the matter.

In the meantime, to make direct links work, I suggest you disable the "SEO friendly clean URLs" feature we added to our WordPress plugin recently. Here's how:
  • Go to your WordPress admin → Ecwid store → Advanced.
  • Uncheck the "SEO friendly clean URLs" option.
  • Save the changes — there's a button at the bottom.

That's it. Once you do this, everything should go back to normal.

Hope this was helpful! Please, do let me know if there are any further questions.
__________________
Stacy
Ecwid Customer Care Team
Help Center


⬇ Please click Thanks if my reply helped you.
Reply With Quote
  #3  
Old 03-21-2017, 05:32 PM
Stacy_P's Avatar
Stacy_P Stacy_P is offline
Ecwid Team
 
Join Date: Jan 2016
Posts: 283
Default

Quote:
Originally Posted by Ladystrange View Post
So if you start on my front page - you can click through to a product page. Once you are on the product page and you click refresh- you get the oops that page cant be found. Also if you take the url and copy paste it in a new tab -you get the same error. Most of the links in my sitemap also points to the oops page. I have the newest wordpress, with the newest akismet , the newest yoast, and the newest ecwid installed and that is it. I tried deactivating the other 2 plug ins and the problem remained with just ecwid installed. I need the idiots guide to fixing this issue please, thank you
Hello,

I have an update for you on this issue. Thank you for your patience.

We have fixed the issue with SEO URLs for stores added to the home page of Wordpress sites. So you can update your Ecwid plugin to the latest version (5.0.5) and enable SEO URLs now.

Thank you!
__________________
Stacy
Ecwid Customer Care Team
Help Center


⬇ Please click Thanks if my reply helped you.
Reply With Quote
  #4  
Old 10-31-2017, 06:47 PM
Paula Wise's Avatar
Paula Wise Paula Wise is offline
 
Join Date: Oct 2017
Posts: 1
Default

Hi, I have the latest version of Ecwid and I'm having this exact same problem. I went to WordPress admin → Ecwid store → and I have simply failed to find any "advanced" link anywhere. Any help on fixing this issue would be greatly appreciated. Thanks
Reply With Quote
  #5  
Old 11-01-2017, 11:06 AM
Elaine V's Avatar
Elaine V Elaine V is offline
Ecwid Team
 
Join Date: Sep 2016
Posts: 43
Default

Hi Paula,

I'm very sorry for the issue. If I concluded correctly, category and product pages in your Wordpress website go to 404 when refreshed. Please try out the solution I've offered you by email: open the Settings > Permalinks page in your Wordpress back-end. This simple action may help.

As regards the "Advanced" section where you can disable SEO friendly URLs, you should see the link to it below "Ecwid" in the left-side navigation in Wordpress back-end after you click on it. Please see the screenshot: http://take.ms/6522L

If the issue persists, please provide us with the access info for your Wordpress site so that we can investigate it further. Thank you!
__________________
Elaine,
Ecwid Team
Reply With Quote
Reply

Tags
404

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:50 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.