The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 10-31-2014, 07:33 PM
Arka's Avatar
Arka is offline
 
Join Date: Mar 2014
Posts: 97
Default

Impossible to modify store in Wordpress (Rather urgent...)


Don't understand this one...
Now the page where my shop is works fine, but if I try to alter it in any way, i.e. if I try to edit the page using wordpress and then save it, I get the following error:
Quote:
Fetching of original content failed with the following error: Proxy Publisher Failure - CONNECTION ERROR. If you own this domain, please consult this FAQ.
I checked the FAQ and I first thought it was my provider, but I don't think that is the case as the only affected page is the one containing the shop.

If I take away the code
Code:
<div>
<script>
ecwidMessages = {
"DownloadError.content.limit":"     Il\: {filename} è stato già scaricato.",
"EgoodsComponent.after_downloads":"&nbsp;per <span>{downloads} download</span>",
"Messages.paid":"Pagato",
"EgoodsComponent.expires":"Valido",
"OrderConfirmation.we_recommend":"Se vuoi, <span id\='printLink'></span>&nbsp;",
"PaymentDetails.enter_email":"Inserisci la tua email",
"PlaceOrder.review_below":"Controlla le informazioni seguenti, quindi fai clic su \"invia l'ordine\"",
"SharePurchase.i_just_bought":"Ho appena acquistato \"La questione cibo\" in",
"TableProductsContainer.add_to_bag":"Aggiungi al carrello"
}
</script>
<script type="text/javascript" src="//app.ecwid.com/script.js?4486221" charset="utf-8"></script>
<script type="text/javascript">
 xProductBrowser("categoriesPerRow=3","views=table(3)","categoryView=table","searchView=table","style=","responsive=yes"); 
</script>
<noscript>Il tuo browser non supporta JavaScript, per cui <a href="https://app.ecwid.com/jsp/4486221/catalog">clicca qui per una versione HTML di questa pagina.</a></noscript>
</div>
then I can preview it, save it, whatever... (and also the widgets in the side bar are still there.

I have not changed anything... Where could the problem be? Have you got any idea?

I could not find this error in the forum, so I really don't know... Is it my provider? Is it yourselves?

_____________

UPDATE:

The problem seems to be with
<script></script>
Whenever I have that, even with nothing inside it, I get the above error. <noscript> doesn't produce the same error.

This seems to point to the provider...
Any ideas?

Last edited by Arka; 10-31-2014 at 10:34 PM.
  #2  
Old 11-20-2014, 02:52 PM
enot's Avatar
enot enot is offline
 
Join Date: Oct 2014
Posts: 499
Default

Quote:
Originally Posted by Arka View Post
Don't understand this one...
Now the page where my shop is works fine, but if I try to alter it in any way, i.e. if I try to edit the page using wordpress and then save it, I get the following error:

I checked the FAQ and I first thought it was my provider, but I don't think that is the case as the only affected page is the one containing the shop.

If I take away the code
then I can preview it, save it, whatever... (and also the widgets in the side bar are still there.

I have not changed anything... Where could the problem be? Have you got any idea?

I could not find this error in the forum, so I really don't know... Is it my provider? Is it yourselves?

_____________

UPDATE:

The problem seems to be with
<script></script>
Whenever I have that, even with nothing inside it, I get the above error. <noscript> doesn't produce the same error.

This seems to point to the provider...
Any ideas?
Hello!

Sorry for taking so terribly long to reply.

I’ve looked through the possible sources of such error message, and it looks like in this case it’s not an Ecwid or provider issue: messages with such wording are usually generated by Google Pagespeed service. And it looks like you are using a PageSpeed plugin for WordPress on your website, so I have to assume that it’s it that generates those error messages.

About the solution:

For example, it was discussed here, and it looks like in their case they solved the problem:
https://groups.google.com/forum/#!to...ss/uU5d7ReBXgs
  #3  
Old 11-20-2014, 05:05 PM
Arka's Avatar
Arka Arka is offline
 
Join Date: Mar 2014
Posts: 97
Default

Hi Stephan,

I forgot to update this pest.

In the end the error went of its own volition, or at least I did nothing...

I SUSPECT there was some incompatibility between my hosting and Google Page service.
Google told me to try this:

Quote:
To implement X-forwarded-for on your domain we suggest you some steps to follow as below:

1.You need to edit the wp-config.php file located in the root of your site. At the top of the file (? And after the <php), add this code snippet:

// ** Wordpress x-forwarded-for ip fix ** //
if(isset($_SERVER['HTTP_X_FORWARDED_FOR'])) {
$xffaddrs = explode(',',$_SERVER['HTTP_X_FORWARDED_FOR']);
$_SERVER['REMOTE_ADDR'] = $xffaddrs[0];
}

2. Now, disable the rewriters as per the first screenshot attached.

3. Then, flush caches as per the second screenshot and then turn rewriter again.

It will take 24 to 48 hours to propagate successfully.

http://www.seeyar.fr/pss-proxy-publisher-failure/ - for screenshots
I leave it here in case it helps someone else with the same problem as me.
However I have to say that the problem went BEFORE I implemented that.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:20 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.