The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 11-02-2012, 08:17 AM
Thais Zoe's Avatar
Thais Zoe is offline
Webpartner
 
Join Date: Mar 2012
Posts: 32
Default

Shipping to Hawaii, Alaska, USVI & Puerto Rico


I am using the updated shipping and have (several times) set up zones and shipping correctly, as far as I can tell, but it is not reflected in my shopping cart.

I want to ship Flat Fee FREE to contiguous US and a Flat Fee $9 to Hawaii, Alaska, USVI and Puerto Rico.

I first set up the ZONES and then under Shipping defined METHODS (Free & $9) then selected by zones "US" and "US Expanded." It shows the latter under shipping methods as $9.00, but when I get to check out it shows that shipping is $0.00 and cannot be calculated until an address is selected. That makes sense. But, I click the asterisked change button, then select US: Virgin Islands, and the box pops up a Hawaii, Alaska, USVI and Puerto Rico option, but at $0.00 NOT at $9.00

How do I correct this? What am I missing? I feel that I've tried EVERYTHING!

SOS!

Thank you...
Thais Zoe
  #2  
Old 11-02-2012, 11:47 AM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Hi,

I've examined your Ecwid shop. You configured shipping rightly so there're two shipping methods: one is free shipping for USA only, the other one for these 4 states with flat rate $9.
But on checkout customers from Alaska, Hawaii, USVI or Puerto Rico should receive two shipping choices: free shipping and $9 flat rate.
It is because you have two zones right now:
- Alaska, Hawaii, USVI or Puerto Rico
- USA covering all states including the above four
So these zones are cross-related, customer from e.g. Alaska is considered from both zones hence get two shipping methods.

To solve this, you should do the following:

1. Add one more zone with the following parameters:
Country - USA
States - all states except for Alaska, Hawaii, USVI an Puerto Rico

(It's necessary to keep the current USA zone and create a new one because you might have taxes that will be applied to all the US states. In this case your current USA zone will be the right one to use)

2. Assign this new zone to shipping method "FREE shipping in the USA"

By the way, shipping method Alaska, Hawaii, USVI & Puerto Rico is disabled right now in Ecwid control panel, System Settings -> Shipping page. Please make sure it's enable when you start testing shipping.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
The Following User Says Thank You to Lanna For This Useful Post:
Thais Zoe (11-02-2012)
  #3  
Old 11-12-2012, 06:01 AM
Thais Zoe's Avatar
Thais Zoe Thais Zoe is offline
Webpartner
 
Join Date: Mar 2012
Posts: 32
Default

Hi Lana,

I couldn't get expanded shipping to work by adding a 3rd zone.
However, I did something else that seems simpler, and I think I can get it working with a little more help from you.

I adjusted my existing "zones" to:
US Contiguous > All US states EXCEPT Alaska, Hawai, Puerto Rico and USVI
and
US Expanded > ONLY Alaska, Hawai, Puerto Rico and USVI

I also assigned a $0 flat rate to US Contiguous and a $9 flat rate to US Expanded.

For "shipping" I assigned the:

US Contiguous zone to Free Shipping in the Contiguous US
and the
US Expanded Zone to Alaska, Hawai, Puerto Rico and USVI

When I test the checkout and enter a California shipping address it gives me the US Contiguous zone for $0, which is correct.

However, when I test the checkout and enter a Hawaii shipping address it gives me the US Expanded zone, for $0, instead of $9.

This seems to be the only hiccup remaining with my shop before I launch Wednesday.
I hope we can get it solved prior to them.

Thank you!
Thais Zoe
  #4  
Old 11-12-2012, 02:40 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by Thais Zoe View Post
Hi Lana,

I couldn't get expanded shipping to work by adding a 3rd zone.
However, I did something else that seems simpler, and I think I can get it working with a little more help from you.

I adjusted my existing "zones" to:
US Contiguous > All US states EXCEPT Alaska, Hawai, Puerto Rico and USVI
and
US Expanded > ONLY Alaska, Hawai, Puerto Rico and USVI

I also assigned a $0 flat rate to US Contiguous and a $9 flat rate to US Expanded.

For "shipping" I assigned the:

US Contiguous zone to Free Shipping in the Contiguous US
and the
US Expanded Zone to Alaska, Hawai, Puerto Rico and USVI

When I test the checkout and enter a California shipping address it gives me the US Contiguous zone for $0, which is correct.

However, when I test the checkout and enter a Hawaii shipping address it gives me the US Expanded zone, for $0, instead of $9.

This seems to be the only hiccup remaining with my shop before I launch Wednesday.
I hope we can get it solved prior to them.
Hi,

I've checked your Ecwid settings. All your products have shipping freight setting enabled with 'Free' option. With this setting each product has individual shipping and disregards the shipping rates that you configured in System Setting -> Shipping. That's why when you try to buy from a US Expanded region you still receive $0 shipping.

So to solve this, you should update your products this way:
- Catalog -> Products -> open the product page -> tab 'Tax and Shipping'
- choose 'Use Global Settings'
- click 'Save'.

You can keep the shipping freight option as 'Free' for those products that you want to ship for free to all your zones.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #5  
Old 11-13-2012, 04:50 AM
Thais Zoe's Avatar
Thais Zoe Thais Zoe is offline
Webpartner
 
Join Date: Mar 2012
Posts: 32
Default

Genius! Thank you, Lana

I'm happy that's solved and I'm just waiting for a reply from Eugene on this this thread located at: http://www.ecwid.com/forums/showthre...7&goto=newpost

Do you have any insight? I'm counting down the hours til I launch and this is the final issue that needs resolve.

Thanks again! Thais
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
flat rate, shipping

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:05 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.