The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 08-14-2012, 04:36 PM
SMART PHONE B1000J's Avatar
SMART PHONE B1000J is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Exclamation

Slow in Blogger


Hello.

This is my store in blogger.

http://android-smartphone-b1000j.blogspot.com

This is very slow....

Can you help me ?

Thanks
  #2  
Old 08-15-2012, 12:34 PM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Thank you for the report. As far as I can see, it takes too long for the page to load completely, and most of the time the Ecwid's loading animation is shown. It is not something about specifically Blogger or Ecwid. This is caused by some images used on your site. Ecwid store is working fast after the loading has been completed.

Ecwid store loads in 3 phases, as the customer's browser loads your store page:
1. The store's main script (//app.ecwid.com/script.js?NNNNN) is loaded into the page.

2. The additional assets of Ecwid (your custom CSS theme and some more Ecwid scripts) is loaded into the page. At this moment, Ecwid shows the loading bar indicator. Only the indicator is visible up from this point.

--- then the browser continues loading the page and its assets - images, other scripts, Flash movies etc. Ecwid is still displayed as a loading bar indicator, no widgets is displayed yet ---

3. Once all the other assets of the page are completely downloaded, the widgets of Ecwid are displayed. Loading bar is removed from the page, and the visual representation of Ecwid's widgets starts appearing on screen.

So, the loading bar is shown for a long time, because something else besides Ecwid on that page is being loaded for too long, and Ecwid waits when that other asset completes and only then starts showing its widgets.

Exactly the image under this URL:
Code:
https://www.paypalobjects.com/es_XC/MX/Marketing/i/banner/bnr_int1_270x61.gif
is being loaded for about 30 seconds. It's this one image on the site:


If you remove it, your site will load faster and Ecwid will be loaded in a blaze.
  #3  
Old 08-15-2012, 02:12 PM
SMART PHONE B1000J's Avatar
SMART PHONE B1000J SMART PHONE B1000J is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Smile

Thanks...

I going to change this image,,, bye..
  #4  
Old 12-15-2012, 08:19 PM
jwillius's Avatar
jwillius jwillius is offline
Junior Member
 
Join Date: Aug 2012
Posts: 16
Default

Eugene -- I'm having a similar problem. My site seems to load everything within a reasonable amount of time except for the "Add to Bag" buttons of my store.
I'm afraid I've lost 90 percent of my potential sales at my store because of this.
Could you please check my situation and suggest a remedy?

Many thanks -- Jeff

Oh, Eugene -- Here's my store: http://www.onemanswonder.com/p/order...-new-book.html
BTW, I have pretty fast Internet connection, and the buttons are taking a full MINUTE to load! Argh!

Last edited by Eugene Rimmer; 12-17-2012 at 09:24 AM.
  #5  
Old 12-17-2012, 10:28 PM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Quote:
Originally Posted by jwillius View Post
Eugene -- I'm having a similar problem. My site seems to load everything within a reasonable amount of time except for the "Add to Bag" buttons of my store.
I'm afraid I've lost 90 percent of my potential sales at my store because of this.
Could you please check my situation and suggest a remedy?

Many thanks -- Jeff

Oh, Eugene -- Here's my store: http://www.onemanswonder.com/p/order...-new-book.html
BTW, I have pretty fast Internet connection, and the buttons are taking a full MINUTE to load! Argh!
The reason is the same as here: http://www.ecwid.com/forums/showthre...0258#post60258 , but there are lots of widgets in your sidebar, and the slowest of them is seemingly the StumbleUpon one.
The Following User Says Thank You to Eugene Rimmer For This Useful Post:
jwillius (12-18-2012)
  #6  
Old 12-18-2012, 05:11 PM
jwillius's Avatar
jwillius jwillius is offline
Junior Member
 
Join Date: Aug 2012
Posts: 16
Default

You're a life-saver, Eugene -- thank you so much! As you suggested, removing the Stumble Upon widget alone sped up the load time for my Add To Bag stuff from over a minute to about 45 seconds. Wow, it's like having Roto Rooter clear a plugged drain!!
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
blogger, slow

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:37 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.