The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 11-06-2011, 09:58 PM
Sunshine Pantry's Avatar
Sunshine Pantry is offline
Junior Member
 
Join Date: Nov 2011
Posts: 1
Question

Category Photos Display, Product Photos Don't...


Hi, I have a problem and I'm sure it's just something stupid that I'm missing ;-)

I have created a store with three categories; each category has a photo attached to it. Within the categories I have assigned products, and again each has a picture.

when I view the store, on the storefront page the category photos display. But when I click on the category itself to view the products I see nothing but the default camera image for each product. It's as if I haven't uploaded anything, but I have!

I should note that if I click on the product itself, the thumbnail appears on the right hand side. But it's going to be tough to get people to click on the product in the first place without a nice picture!

What am I missing?

https://app.ecwid.com/jsp/803309/simple-store
  #2  
Old 11-07-2011, 11:49 AM
Matt Ecwid's Avatar
Matt Ecwid Matt Ecwid is offline
Ecwid Team
 
Join Date: Oct 2011
Posts: 4,947
Default

Quote:
Originally Posted by Sunshine Pantry View Post
Hi, I have a problem and I'm sure it's just something stupid that I'm missing ;-)

I have created a store with three categories; each category has a photo attached to it. Within the categories I have assigned products, and again each has a picture.

when I view the store, on the storefront page the category photos display. But when I click on the category itself to view the products I see nothing but the default camera image for each product. It's as if I haven't uploaded anything, but I have!

I should note that if I click on the product itself, the thumbnail appears on the right hand side. But it's going to be tough to get people to click on the product in the first place without a nice picture!

What am I missing?

https://app.ecwid.com/jsp/803309/simple-store
Each product in Ecwid store can have one main image - the thumbnail image - and many additional detailed ones - the gallery images. A main product image is displayed both in the products list and on the product details page. This image can be assigned to a product under the 'General' tab of the product details page in your Ecwid control panel. Look at the following screenshot:
http://www.diigo.com/item/image/1xdw9/2e5j?size=o

The gallery images, on the other hand, are not shown in the category listings. They serve as additional detailed images for the product, their thumbnails are shown below the right panel with the product price and the "Add to cart" button on the product details page. Additional product images can be managed under the 'Gallery' tab of the product details page ( http://www.diigo.com/item/image/1xdw9/r8pi?size=o ). The gallery images are not connected with product thumbnail image anyway - if you upload one or more gallery images, they only appear in the product gallery, and none of them becomes a product thumbnail in the listings.

So, if you want to see the product thumbnails in the category listing, you need to upload the images in the General tabs of those products in the Ecwid control panel. If, however, you want to add more detailed images to a particular product, you can upload them in the Gallery tab.

Read the following article to get more info about the additional product images in Ecwid:
http://kb.ecwid.com/w/page/29133609/...e%20gallery%29

I also want to note that product thumbnails in Ecwid aren't displayed when products are listed using the 'Table' layout. So for being able to see thumbnails in a products list, make sure you use the 'Grid' or the 'List' layout styles ( http://www.diigo.com/item/image/1xdw9/97en?size=o )

I have checked your store. All looks good from my side. Please look at the screenshot:
http://www.diigo.com/item/image/1xdw9/a4e2?size=o

So I guess you have dealt with a problem, right?
__________________
Matt K
Ecwid Team

Ecwid Guide for Beginners

Ecwid Help Center

Ecwid video tutorials
The Following User Says Thank You to Matt Ecwid For This Useful Post:
Madison Power Systems (08-15-2012)
  #3  
Old 11-18-2012, 06:44 PM
ClassySuits's Avatar
ClassySuits ClassySuits is offline
 
Join Date: Dec 2010
Posts: 5
Default

Hello, I am also having that problem with no images being shown in the product page. I have placed images under the general tab and when you click on the image, there is none shown next to the description.
http://www.sexyloversgifts.com/store...89&id=15562583
this is happening with several of my stores

http://www.classysuits4men.com/store...68&id=17151685
http://www.discountdivastyles.com/sh...29&id=17151413

They all have images under the general tab, and in the gallery, but they still dont' show up. Can someone assist?

Thank you,
  #4  
Old 11-19-2012, 09:17 AM
Kess's Avatar
Kess Kess is offline
Senior Member
 
Join Date: Feb 2012
Posts: 2,071
Default

Quote:
Originally Posted by ClassySuits View Post
Hello, I am also having that problem with no images being shown in the product page. I have placed images under the general tab and when you click on the image, there is none shown next to the description.
http://www.sexyloversgifts.com/store...89&id=15562583
this is happening with several of my stores

http://www.classysuits4men.com/store...68&id=17151685
http://www.discountdivastyles.com/sh...29&id=17151413

They all have images under the general tab, and in the gallery, but they still dont' show up. Can someone assist?

Thank you,
The issue has place because of the following rule in your Wordpress theme:
Code:
.entry-content td{
border:none;
width:50%
}
The width value prevents your products thumbnails from being displayed on the product pages. To fix it, please add the following CSS rule to your Ecwid control panel -> System Settings -> Design -> CSS Themes:

Code:
.entry-content td{
width:auto;
}
and click "Save (Ctrl+S)".
The Following User Says Thank You to Kess For This Useful Post:
ClassySuits (11-20-2012)
  #5  
Old 12-01-2013, 06:04 AM
Anthony Varriano's Avatar
Anthony Varriano Anthony Varriano is offline
Junior Member
 
Join Date: Dec 2013
Posts: 3
Default Didn't work for me...

Quote:
Originally Posted by Kess View Post
The issue has place because of the following rule in your Wordpress theme:
Code:
.entry-content td{
border:none;
width:50%
}
The width value prevents your products thumbnails from being displayed on the product pages. To fix it, please add the following CSS rule to your Ecwid control panel -> System Settings -> Design -> CSS Themes:

Code:
.entry-content td{
width:auto;
}
and click "Save (Ctrl+S)".
Tried this. It didn't work. Photos still don't show up in any aspect...on the products page or the product description page.
  #6  
Old 12-02-2013, 04:14 PM
Liza P's Avatar
Liza P Liza P is offline
Ecwid Team
 
Join Date: Jan 2013
Posts: 2,517
Default

Quote:
Originally Posted by Anthony Varriano View Post
Tried this. It didn't work. Photos still don't show up in any aspect...on the products page or the product description page.
Hello,

In order to fix this you need to modify your site CSS theme a little. The line 1595 of this file:http://gogonzojournal.com/wp-content...cast/style.css has the following rule:

Code:
.js_active #main img{
visibility: hidden;
}
Please, change the "hidden" value I marked red, with the "visible" value.
__________________
Liza P.
Customer Care
Ecwid Help Portal
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
gallery, photos, products

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:52 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.