The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 05-21-2010, 06:58 PM
North Country Fudge Shoppe's Avatar
North Country Fudge Shoppe is offline
 
Join Date: Apr 2010
Posts: 20
Default

IE 8 Errors


I only appear to have this problem in IE8.

I have added the code to my page and it works fine as the categories are displayed, however I receive a page error once the product is added to the cart:

Webpage error details

Timestamp: Fri, 21 May 2010 18:54:34 UTC

Message: Not implemented

Line: 101
Char: 5
Code: 0
URI: http://app.ecwid.com/functions.js

My temp location is http://mcbits.com/ncfudge
Navigate to products tab.
  #2  
Old 05-21-2010, 07:38 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by North Country Fudge Shoppe View Post
I only appear to have this problem in IE8.

I have added the code to my page and it works fine as the categories are displayed, however I receive a page error once the product is added to the cart:

Webpage error details

Timestamp: Fri, 21 May 2010 18:54:34 UTC

Message: Not implemented

Line: 101
Char: 5
Code: 0
URI: http://app.ecwid.com/functions.js

My temp location is http://mcbits.com/ncfudge
Navigate to products tab.
Hm, I cannot reproduce this issue in my IE8.

Can you reproduce this error at http://app.ecwid.com/jsp/107031/simple-store ?
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base

Last edited by qetzal; 05-21-2010 at 08:26 PM.
  #3  
Old 05-21-2010, 08:09 PM
North Country Fudge Shoppe's Avatar
North Country Fudge Shoppe North Country Fudge Shoppe is offline
 
Join Date: Apr 2010
Posts: 20
Default

I don't receive the error on the link you sent, however after trying on another computer in our office, I get the error on the original link I sent you as well. I've attached a screen shot. It appears to be fine in compatibility mode in ie8 as well as Firefox, but ie8 without compatibility mode gives the error. What gets affected is the shopping bag positioning i believe. Sometimes it will be half off the screen. As another note, the link you sent me gives a security warning when loading about "some information on this page may not being delivered securely".
Attached Thumbnails
Click image for larger version

Name:	screenshot.gif
Views:	111
Size:	92.4 KB
ID:	316  

Last edited by North Country Fudge Shoppe; 05-21-2010 at 08:13 PM.
  #4  
Old 05-21-2010, 08:40 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by North Country Fudge Shoppe View Post
I don't receive the error on the link you sent, however after trying on another computer in our office, I get the error on the original link I sent you as well. I've attached a screen shot. It appears to be fine in compatibility mode in ie8 as well as Firefox, but ie8 without compatibility mode gives the error. What gets affected is the shopping bag positioning i believe. Sometimes it will be half off the screen. As another note, the link you sent me gives a security warning when loading about "some information on this page may not being delivered securely".
1. The link I posted was incorrect, I've edited my message. If you try to open it now, it will not show a warning.

2. Could you please post exact steps you do to reproduce this error? Thank you in advance.
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #5  
Old 05-21-2010, 08:50 PM
North Country Fudge Shoppe's Avatar
North Country Fudge Shoppe North Country Fudge Shoppe is offline
 
Join Date: Apr 2010
Posts: 20
Default

Eugene,

Here is what I can tell so far. If there is no product in the bag, the error does not happen. Once there is product in the bag, it happens as soon as I load the products page or any of the ecwid pages thereafter. The bag also ends up positioned off the page viewing area when I naviagte to other ecwid parts. So for example in the screenshot I sent you, the bag is not showing on the screen, I had to scroll down to view the bag. Whenever there is nothing in the bag, it always positions itself in the proper place on the right hand side.

Also, I still get no errors on the updated page that you sent me.

Last edited by North Country Fudge Shoppe; 05-21-2010 at 08:53 PM.
  #6  
Old 05-21-2010, 09:05 PM
North Country Fudge Shoppe's Avatar
North Country Fudge Shoppe North Country Fudge Shoppe is offline
 
Join Date: Apr 2010
Posts: 20
Default

I was able to stop the error...I think so far. I had not added the bag widget code. Now that I added that to the page, the error does not occur. I will continue testing and be back if I have questions. Thanks Eugene!
  #7  
Old 05-23-2010, 12:43 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by North Country Fudge Shoppe View Post
I was able to stop the error...I think so far. I had not added the bag widget code. Now that I added that to the page, the error does not occur. I will continue testing and be back if I have questions. Thanks Eugene!
Hm, do you mean that the error appears when minicart is installed on your page?
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #8  
Old 05-24-2010, 05:10 PM
North Country Fudge Shoppe's Avatar
North Country Fudge Shoppe North Country Fudge Shoppe is offline
 
Join Date: Apr 2010
Posts: 20
Default

The error has gone since I put the bag widget code on the page.
  #9  
Old 05-25-2010, 12:44 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by North Country Fudge Shoppe View Post
The error has gone since I put the bag widget code on the page.
Thank you for the information. Glad to know that the issue is fixed.
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:53 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.