The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 11-07-2014, 08:47 AM
lilzippers's Avatar
lilzippers is offline
 
Join Date: May 2012
Posts: 3
Default

Multiple Installations of Google Tag Manager installed on page containing Ecwid shop


I have a single Google Tag Manager (GTM) script just after the <body> tag of my shop page (http://www.lilzippers.com.au/shop.php).

Following that is the Ecwid bag widget code, category tabs and product browser.

The problem is when I access any category in the store (eg. Store > Boys), Google Tag Assistant reports that I have multiple installations of Tag Manager. In the list of tags, I see two identical Google Tag Manager tags. Please see attachment.

If I go down another sub-category (eg. Store > Boys > Boy's Zip Growsuits), another Google Tag Manager tag appears in Tag Assistant. Now there are three.

Then if I open a product detail page, I get another duplicate tag - four in total.

In fact as I browse the shop, with each page another Tag is added.

If I go to another page besides the shop, the number of tags resets back to one.

The html source of the shop page definitely only has the one instance of GTM.

I am concerned about potential impact on statistics and performance decreasing as the number of duplicate tags increase.

Any assistance would be gratefully received.
Attached Thumbnails
Click image for larger version

Name:	Capture1.jpg
Views:	385
Size:	52.6 KB
ID:	2783  
  #2  
Old 12-09-2014, 12:48 PM
Axiom
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by lilzippers View Post
I have a single Google Tag Manager (GTM) script just after the <body> tag of my shop page (http://www.lilzippers.com.au/shop.php).

Following that is the Ecwid bag widget code, category tabs and product browser.

The problem is when I access any category in the store (eg. Store > Boys), Google Tag Assistant reports that I have multiple installations of Tag Manager. In the list of tags, I see two identical Google Tag Manager tags. Please see attachment.

If I go down another sub-category (eg. Store > Boys > Boy's Zip Growsuits), another Google Tag Manager tag appears in Tag Assistant. Now there are three.

Then if I open a product detail page, I get another duplicate tag - four in total.

In fact as I browse the shop, with each page another Tag is added.

If I go to another page besides the shop, the number of tags resets back to one.

The html source of the shop page definitely only has the one instance of GTM.

I am concerned about potential impact on statistics and performance decreasing as the number of duplicate tags increase.

Any assistance would be gratefully received.
Hello!

I’m really sorry for the delay!
As far as I can see you are using the Google Tag Manager (GTM), right?
Also you are using Google Analytics (GA).

In order to stop duplicating tags on your store’s page try this script (To add new tag you need to click New (on the panel) and select Tag):

Code:
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TV3H62"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>$(document).ready(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TV3H62');</script>
<!-- End Google Tag Manager →
The difference between yours and this script is in: ‘$(document).ready’.
This parameter will force code execution only after page (document) will be fully loaded. The page can be loaded only one time for the page loading time. Thus, it’ll stop duplicating tags in your store.
  #3  
Old 12-11-2014, 11:40 AM
lilzippers's Avatar
lilzippers lilzippers is offline
 
Join Date: May 2012
Posts: 3
Default

Thanks for responding, Paul.

Yes I have GA, in fact I have a Universal Analytics tag inside my tag container firing on All Pages (please see screenshot).

After I replaced the GTM code with yours, the behaviour is exactly as it is when no GTM is installed (I have proven this by taking out all GTM code completely). That is:
- When I'm in any page but the shop (in which ecwid is embedded), there are no tags found by Tag Assistant - please see first screenshot.
- When I'm in the shop there is one UA tag and always one no matter how many levels deep I go into the store - please see second screenshot.

So from this would you conclude that the new code does not appear to be working at all?

I was actually surprised to see the UA tag, after I removed the GTM container. Is that put in by Ecwid automatically? I wonder if having GTM containing a UA tag and separate UA tag together is causing any issue? I can definitely confirm it is GTM that is duplicating, not the UA tag (see third screenshot).
Attached Thumbnails
Click image for larger version

Name:	11-12-2014 10-11-21 PM.png
Views:	274
Size:	17.9 KB
ID:	2828   Click image for larger version

Name:	11-12-2014 10-14-46 PM.png
Views:	293
Size:	10.9 KB
ID:	2830   Click image for larger version

Name:	11-12-2014 10-33-46 PM.png
Views:	332
Size:	16.5 KB
ID:	2831   Click image for larger version

Name:	GTM contents.png
Views:	254
Size:	37.9 KB
ID:	2832  
  #4  
Old 12-18-2014, 09:06 AM
Axiom
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by lilzippers View Post
Thanks for responding, Paul.

Yes I have GA, in fact I have a Universal Analytics tag inside my tag container firing on All Pages (please see screenshot).

After I replaced the GTM code with yours, the behaviour is exactly as it is when no GTM is installed (I have proven this by taking out all GTM code completely). That is:
- When I'm in any page but the shop (in which ecwid is embedded), there are no tags found by Tag Assistant - please see first screenshot.
- When I'm in the shop there is one UA tag and always one no matter how many levels deep I go into the store - please see second screenshot.

So from this would you conclude that the new code does not appear to be working at all?

I was actually surprised to see the UA tag, after I removed the GTM container. Is that put in by Ecwid automatically? I wonder if having GTM containing a UA tag and separate UA tag together is causing any issue? I can definitely confirm it is GTM that is duplicating, not the UA tag (see third screenshot).
Hello!

Sorry for the delayed response.
I’ve checked your site and it looks like Google Analytics may affect Google Tag Manager.

I need more information for our developers about your issue.
Please do the following and let me know the results: remove Google Analytics ID from your Ecwid Control panel (System settings>Store profile>Google Analytics ID). Does the issue with duplicating tags persist? The screenshots of what you see will also be of great help.

Looking forward to hearing from you!
  #5  
Old 01-30-2015, 06:38 AM
Liza P's Avatar
Liza P Liza P is offline
Ecwid Team
 
Join Date: Jan 2013
Posts: 2,517
Default

Quote:
Originally Posted by lilzippers View Post
Thanks for responding, Paul.

Yes I have GA, in fact I have a Universal Analytics tag inside my tag container firing on All Pages (please see screenshot).

After I replaced the GTM code with yours, the behaviour is exactly as it is when no GTM is installed (I have proven this by taking out all GTM code completely). That is:
- When I'm in any page but the shop (in which ecwid is embedded), there are no tags found by Tag Assistant - please see first screenshot.
- When I'm in the shop there is one UA tag and always one no matter how many levels deep I go into the store - please see second screenshot.

So from this would you conclude that the new code does not appear to be working at all?

I was actually surprised to see the UA tag, after I removed the GTM container. Is that put in by Ecwid automatically? I wonder if having GTM containing a UA tag and separate UA tag together is causing any issue? I can definitely confirm it is GTM that is duplicating, not the UA tag (see third screenshot).
Hello,

We need some more details for further investigation of this issue. Can you, please, provide us with those?

Please, try to disable Google Analytics in your Ecwid control panel on the System settings -> General -> Store profile page. Does the issue with duplicating tags occur when GA is disabled in Ecwid?

Thank you in advance. We really appreciate your assistance.
__________________
Liza P.
Customer Care
Ecwid Help Portal
  #6  
Old 01-31-2015, 03:37 AM
lilzippers's Avatar
lilzippers lilzippers is offline
 
Join Date: May 2012
Posts: 3
Default

Hi Liza,

After removing the UA ID from the Store Profile the behaviour changed.

I no longer get an extra GTM for each Category I visit.

However, it still adds one for every Product Detail page I visit.

Screen shots attached:
The following four are with UA ID saved in Store Profile:
CategoryGTA
SubCategoryGTA
ProductDetalGTA

The following are with the UA removed from Store Profile:
CategoryGTA_noUAID
SubCategoryGTA_noUAID
ProductDetalGTA_noUAID
ProductDetal2GTA_noUAID

Hope this helps. Thanks.
Attached Thumbnails
Click image for larger version

Name:	CategoryGTA.PNG
Views:	252
Size:	84.3 KB
ID:	2881   Click image for larger version

Name:	CategoryGTA_noUAID.PNG
Views:	268
Size:	71.0 KB
ID:	2882   Click image for larger version

Name:	SubCategoryGTA.PNG
Views:	248
Size:	40.6 KB
ID:	2883   Click image for larger version

Name:	SubCategoryGTA_noUAID.PNG
Views:	286
Size:	26.4 KB
ID:	2884   Click image for larger version

Name:	ProductDetailGTA.PNG
Views:	253
Size:	60.0 KB
ID:	2885  

Click image for larger version

Name:	ProductDetailGTA_noUAID.PNG
Views:	234
Size:	60.0 KB
ID:	2886   Click image for larger version

Name:	ProductDetail2GTA_noUAID.PNG
Views:	228
Size:	47.8 KB
ID:	2887  
  #7  
Old 02-03-2015, 03:51 PM
Liza P's Avatar
Liza P Liza P is offline
Ecwid Team
 
Join Date: Jan 2013
Posts: 2,517
Default

Quote:
Originally Posted by lilzippers View Post
Hi Liza,

After removing the UA ID from the Store Profile the behaviour changed.

I no longer get an extra GTM for each Category I visit.

However, it still adds one for every Product Detail page I visit.

Screen shots attached:
The following four are with UA ID saved in Store Profile:
CategoryGTA
SubCategoryGTA
ProductDetalGTA

The following are with the UA removed from Store Profile:
CategoryGTA_noUAID
SubCategoryGTA_noUAID
ProductDetalGTA_noUAID
ProductDetal2GTA_noUAID

Hope this helps. Thanks.
Hello,

Thank you very much for the provided information. I have forwarded it to our developers. They will investigate the issue. I will update you as soon as I have any information.

Thank you for your patience.
__________________
Liza P.
Customer Care
Ecwid Help Portal
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
google tag manager, tag assistant

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:42 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.