The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 03-04-2013, 07:44 PM
The Mod Cabin's Avatar
The Mod Cabin is offline
 
Join Date: Dec 2012
Posts: 16
Default

Problem with single product widget and Wordpress page


Hi!

I've decided to create an individual wordpress page for each of my products and I'm having trouble with the single product widget displaying properly. There are three main reasons that I'm doing this.

1. Even though I've installed the Ecwid plugin in Wordpress weeks ago, it doesn't appear that my items show up in searches, even when I search for my exact product title and store title together.

2. The product browser widget is not responsive and does not display correctly on tablets and phones.

3. When linking to a product on a social media site (namely Facebook), it's unable to load the product photo, or to even link directly to the product. People who click on the link are taken to the category.

Please advise me if the single product widget installed on it's own page will solve these problems. My other blog pages seemed to be indexed by google quickly. Also, I believe this solution will allow me to build a table for the products on the main page that will be responsive to various sized displays, and should be easily linked to on social media sites. Please let me know if this is a good solution to the problems I listed.

If so, I'll need help with the single product widget. I've attempted to place one product on it's on page but the widget isn't displaying properly. The border that is supposed to be around the widget is below the product and the buy now buttons. You can take a look at it here: http://themodcabin.com/kismet-cleansing-oil/

I appreciate all your help! Thank you
Cori
  #2  
Old 03-08-2013, 03:19 PM
The Mod Cabin's Avatar
The Mod Cabin The Mod Cabin is offline
 
Join Date: Dec 2012
Posts: 16
Default

Well, I've figured out how to remove the border on my own, which I've done since I can't figure out how to place it properly around the price and buy now button. I would still appreciate the help with all my questions above, as well as how to correct the border issue.

Please keep in mind if you visit the page I linked to you won't see the border because I have removed it, but I'd still like feedback on how to change the border from showing up as wide as the page, and below the product details, instead of AROUND the product details. Removing it is a temporary solution.

I'm hoping someone can help me. Thank you.
  #3  
Old 03-10-2013, 03:32 PM
The Mod Cabin's Avatar
The Mod Cabin The Mod Cabin is offline
 
Join Date: Dec 2012
Posts: 16
Default PLEASE HELP

Can someone please help me? I understand that you have a lot of people to help, but when I post a question, and I see people who post after me get their questions answered it's a little frustrating. Especially when it happens repeatedly.

I did a search to see if my store is being indexed, and it appears it is not. Please note that I installed the Ecwid Wordpress plugin over a month ago, so it would have been indexed by now if it was working. This is a screenshot of the results I get. I also tried searching for the same string, but with store.php, and I got the same result. I did rename my store to shop, so please let me know if this can affect the function. I was told I could rename it by Matvey, but they didn't mention whether or not it would affect it being indexed.



All of our traffic is currently coming from social media like Pinterest and Facebook, but I need to know that my products are being indexed or I'll have to find another shopping cart solution.

Can you please, please help me with my questions from this post and the previous posts in this thread?? I would greatly appreciate all help I receive!!
  #4  
Old 03-11-2013, 11:06 AM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Quote:
Originally Posted by The Mod Cabin View Post
Can someone please help me? I understand that you have a lot of people to help, but when I post a question, and I see people who post after me get their questions answered it's a little frustrating. Especially when it happens repeatedly.

I did a search to see if my store is being indexed, and it appears it is not. Please note that I installed the Ecwid Wordpress plugin over a month ago, so it would have been indexed by now if it was working. This is a screenshot of the results I get. I also tried searching for the same string, but with store.php, and I got the same result. I did rename my store to shop, so please let me know if this can affect the function. I was told I could rename it by Matvey, but they didn't mention whether or not it would affect it being indexed.



All of our traffic is currently coming from social media like Pinterest and Facebook, but I need to know that my products are being indexed or I'll have to find another shopping cart solution.

Can you please, please help me with my questions from this post and the previous posts in this thread?? I would greatly appreciate all help I receive!!
Your shop is actually located at http://themodcabin.com/shop/ , not at http://themodcabin.com/shop.php. No wonder Google does not index anything that does not exist on your site. The correct address produces a lot of pages in search: https://www.google.com/search?q=site...hrome&ie=UTF-8 so I cannot see any problem with that.
  #5  
Old 03-11-2013, 03:44 PM
The Mod Cabin's Avatar
The Mod Cabin The Mod Cabin is offline
 
Join Date: Dec 2012
Posts: 16
Default

Eugene,

Thank you for the correction on the site address. Unfortunately, I followed the directions in the Ecwid forum which stated to use the .php extension when searching. Sorry for my confusion.

I had several other points in my first post which was written back on the 4th that I would still like answers for. Search engine indexing was not my only issue. Please read above and let me know what your advice would be.

Thank you.
  #6  
Old 03-12-2013, 09:46 AM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Quote:
1. Even though I've installed the Ecwid plugin in Wordpress weeks ago, it doesn't appear that my items show up in searches, even when I search for my exact product title and store title together.
Addressed above, it does appear in the searches.

Quote:
2. The product browser widget is not responsive and does not display correctly on tablets and phones.
Ecwid is to be responsive soon. We were keen to release the adaptive design with the v.13.1 of Ecwid, but then it turned out to have a major bug, so we rolled back this functionality and now are working on improving it for the next release.

Quote:
3. When linking to a product on a social media site (namely Facebook), it's unable to load the product photo, or to even link directly to the product. People who click on the link are taken to the category.
Here is the example of the liked product from your store - https://www.facebook.com/eugene.efim...ECENT_ACTIVITY - it does have the picture and does take you to the product on the site, not to category. Do you have examples of the problematic likes?
  #7  
Old 03-12-2013, 04:14 PM
The Mod Cabin's Avatar
The Mod Cabin The Mod Cabin is offline
 
Join Date: Dec 2012
Posts: 16
Default

Eugene,

Thank you for your help, and for the update on the responsive version of Ecwid. In the meantime, is my suggestion of building a page for each product and creating my own products grid/table to link to each product a viable solution to the responsive issue?

Also, I believe you "liked" my product through the Ecwid Facebook button on the product, correct? I understand people are able to do that, however, I'm not able to post a link to my product using that function on our company facebook page. Only from our personal page, which is explained in the Ecwid knowledge base. Also, if someone just tries to copy and paste the address to a product and post a link to it on their facebook page that doesn't work, either. That's another reason I was considering making a page for each product using the single product widget.

Please advise me if the single product widget installed on it's own page, with a self built product grid linking to each product, will solve these problems, and what the drawback of doing so would be.

Thank you so much for all your input!!

Cori
  #8  
Old 04-02-2013, 10:11 AM
Matt Ecwid's Avatar
Matt Ecwid Matt Ecwid is online now
Ecwid Team
 
Join Date: Oct 2011
Posts: 4,947
Default

Hi Cori,

Sorry for the delay.


Quote:
Originally Posted by The Mod Cabin View Post
Thank you for your help, and for the update on the responsive version of Ecwid. In the meantime, is my suggestion of building a page for each product and creating my own products grid/table to link to each product a viable solution to the responsive issue?
Of course, you can create separate pages for your products and custom grid/table layout - but in this case you will still need to adjust that layout to the actual screen size. I mean the fact that it is a custom layout doesn't make it responsive automatically - if you put three items in a raw they will display three in raw even on a mobile device unless you add necessary CSS or Javascript for making it responsive.

You can also try this custom solution for your store (you are probably already aware of it):
http://www.ecwid.com/forums/showthread.php?t=13299
It will require some custom programming though.

Please also refer to this detailed post about our plans with regards to responsive design:
http://www.ecwid.com/forums/showthre...1342#post81342


Quote:
Also, I believe you "liked" my product through the Ecwid Facebook button on the product, correct? I understand people are able to do that, however, I'm not able to post a link to my product using that function on our company facebook page. Only from our personal page, which is explained in the Ecwid knowledge base. Also, if someone just tries to copy and paste the address to a product and post a link to it on their facebook page that doesn't work, either. That's another reason I was considering making a page for each product using the single product widget.
It is not necessary to create separate product pages for making them 'likeable'. In fact, Ecwid already has everything for that:
1) FB like buttons on the product pages and on the product lists: http://kb.ecwid.com/w/page/24744046/...andSendbuttons
2) Other share buttons: http://kb.ecwid.com/w/page/53783179/Share%20buttons
3) A tool for admin to share their products right from control panel to any page:
http://kb.ecwid.com/w/page/60502675/...0and%20Twitter

As to pasting your product URLs directly to Facebook, please find the details here:
http://www.ecwid.com/forums/showthre...8821#post38821

I don't think it would be convenient though - using built-in Like buttons seems more convenient for me.
__________________
Matt K
Ecwid Team

Ecwid Guide for Beginners

Ecwid Help Center

Ecwid video tutorials
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
responsive, search engine, single product widget, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:34 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.