The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 03-03-2013, 08:01 AM
Karen Gonzales's Avatar
Karen Gonzales is offline
 
Join Date: Jan 2013
Location: New Mexico
Posts: 12
Default

Slow loading & deleted text still appears


Hi,
I added a line of text to appear on each store page. See Screenshot1. I have since deleted the line and updated it. Now when I try to load my store it cycles through page load numerous times and the deleted line appears (& not the new version Screenshot2) over and over until final page load. Not sure where the line of text is to delete it. What can I do about the front page loading partially, then going blank and trying to load again, numerous times.

I have attached a couple screenshots and the address is moonscoffeeandtea.com

  #2  
Old 03-04-2013, 07:13 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by David Krolick View Post
Hi,
I added a line of text to appear on each store page. See Screenshot1. I have since deleted the line and updated it. Now when I try to load my store it cycles through page load numerous times and the deleted line appears (& not the new version Screenshot2) over and over until final page load. Not sure where the line of text is to delete it. What can I do about the front page loading partially, then going blank and trying to load again, numerous times.

I have attached a couple screenshots and the address is moonscoffeeandtea.com
Hi,

It looks like the text line is added to the page where Ecwid plugin is installed. Please, check your Wordpress admin, Pages -> 'Store' and 'Our-products' - you have Ecwid embedded on these pages.

I've thoroughly inspected your site pages and I'm convinced that the reported issues are most likely to be caused two things: specific setup of categories horizontal links and some 3rd party Wordpress plugins.

When I try to open a category page from, e.g., Teas -> Black Tea, the page tries to open this link:
http://moonscoffeeandtea.com/our-pro...0&sort=nameAsc
Yet it's reloaded and eventually redirected to this:
http://moonscoffeeandtea.com/store/#...0&sort=nameAsc
which is also reloaded once again.

The redirect happens because of the categories links:
Ecwid plugin is installed on page http://moonscoffeeandtea.com/store
Page http://moonscoffeeandtea.com/our-products/ page also contains product browser widget code, but it doesn't display any Ecwid items because the widget code has ecwid_productBrowserURL set to "http://moonscoffeeandtea.com/store". Hence is the redirect from "our-products" pages to "store" pages

To fix it, you need to:
a) remove page "our-products",
b) modify the categories links in the horizontal categories menu and change links so that they look like this:
http://moonscoffeeandtea.com/store/#...0&sort=nameAsc
i.e. they need to direct to the actual store page.

As for the 'store' page to be reloaded once again, probably there's a Wordpress plugin that triggers the page to be reloaded.

Further to the slow loading, please mind, it is not only Ecwid widgets loading time: It is the time of the whole store page loading. When you see the loading bar it means that Ecwid is just waiting for the whole site to be loaded, then displays the widgets. Therefore you should always take into account other elements used on your site: other scripts, heavy pictures, etc.
When you notice a slow loading, we always ask to test the store in different environments in order to find out what causes speed issues:
http://kb.ecwid.com/w/page/25986445/...0to%20fix%20it
Please, try opening your simple store link: http://moonsmobile.ecwid.com/simple-store As long as it's loaded OK, this clearly indicates that the problem is within your web-site.
I've looked through the elements that are loaded on your site pages. I've been able to detect min ~12 scripts (plugins) each taking 1-2 seconds to be loaded, which makes total loading time very high.

Thus, as further troubleshooting step (in addition to the above fix for the categories menu) I suggest the following:
- Please, disable all the plugins (except for Ecwid) in your Wordpress admin zone,
- then enable them one by one and check how the store will be loaded.
It should help identify which of the plugins causes the slow down and reload of the store page mentioned above. Let me know the results.

By the way, when I browse your site I can see the admin bar on the top, here's a screenshot: http://i.imgur.com/WE9BqbS.png It's definitely a Wordpress plugin working incorrectly (because most likely this bar is supposed to be shown only to the site admin when he's signed in). So disabling of the plugins will show us what makes the bar displayed to all visitors.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
The Following User Says Thank You to Lanna For This Useful Post:
Karen Gonzales (03-05-2013)
  #3  
Old 03-05-2013, 03:48 AM
Karen Gonzales's Avatar
Karen Gonzales Karen Gonzales is offline
 
Join Date: Jan 2013
Location: New Mexico
Posts: 12
Default RE: Slow loading & deleted text still appears

Your advice was spot-on. The "Our-Products" page was hidden & I had forgot about it. I updated my menu links and trashed our-products & things instantly got better. I disabled most plug-ins and activated them one at a time. I noticed a slow-down from Spam-Trap & WPTouch for mobile devices. Too Bad.

Svetlana, you're a life-saver and you made a somewhat complicated idea, totally understandable. Thanks, thanks, & thanks again.
David
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:40 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.