The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-07-2014, 10:20 AM
bcglobe's Avatar
bcglobe bcglobe is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Default Single Product Widget Does Not Handle OnPageLoaded Callback

What I have done:
1. Created a product with options (of types SELECT and TEXTFIELD) in ecwid Control Panel

2. Copied the snippet from the product's Product HTML Codes into a blank file named ecwid-html-<product-id>.html

3. Appended these 2 functions to the html file:
<script type="text/javascript">

Ecwid.OnPageLoad.add
(
function(page)
{
alert('LoadingPage:' + page.type);
}
);

Ecwid.OnPageLoaded.add
(
function(page)
{
alert('LoadedPage:' + JSON.stringify(page));
}
);
</script>


4. Opened the file in IE

5. Actual Result: Only "LoadingPage" alert is shown. I am expecting to see "LoadedPage" alert after "LoadingPage" alert.

Kindly advise.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
onpageloaded, single product widget

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:32 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.