The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 03-18-2012, 01:14 PM
Rose Backman's Avatar
Rose Backman is offline
Junior Member
 
Join Date: Mar 2012
Posts: 2
Default

WP: Why does specific page get opened in background when shopping bag link is clicked?


Alright this is with a wordpress install and you can see it happening here:

http://drrosebackman.com/bottom/

on the right hand side i have the shopping bag widget there.. If you click on it it will do the lightbox thing and open it up but in the background it will always load this page http://drrosebackman.com/bottom/serv...kman-2/#ecwid: in the background.

Why is it loading anything in the background, why isn't it just loading ./#ecwid and saving my visitors the time of having a new page loaded and then the box popping up?

I have my store url blank in my settings here because I am running this store on multiple sites and dont want visitors taken to one specific store front everytime they are shopping. They need to stay on the site they are on. If I change the store url to www.domain.com/store then it properly loads that in the background when the users are in their bag and whatnot but if it is blank then it will ALWAYS load that same page, no matter what I do.. I've tried changing the order it has associated with it, i've tried changing it's publish date, I have no idea why ecwid is choosing that page amongst all of the others.

So ideally I would like to figure out how to have the card not load any page int he background when the js is called, ie from clicking the shopping bag link, but if that is humanly impossible then how can I change which page is loaded in the background? If I knew what criteria ecwid was using to select that page I could modify my ./store/ page attribute so it would choose that one.

Thanks for your help
  #2  
Old 03-18-2012, 01:21 PM
Rose Backman's Avatar
Rose Backman Rose Backman is offline
Junior Member
 
Join Date: Mar 2012
Posts: 2
Default

Alright, nevermind.. 30 seconds later I solved my own problems.

just go into the ecwid plugin directory and edit the main php file

search for ecwid_ProductBrowserURL and you'll notice it bringing up the $store variable.. Take that out and replace it with whatever path you want.. I put in .\/store\/ in there and while it doesn't do the fancy popup box anymore it loads everything in the main page whiich works just as well..
  #3  
Old 03-19-2012, 08:43 AM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

To correct the setup of your WordPress install, please refer to this article: http://kb.ecwid.com/w/page/15853324/...atshouldIdonow
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
background, loading, page, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:21 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.