The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 03-09-2016, 01:39 PM
Keita @ CIA's Avatar
Keita @ CIA is offline
Junior Member
 
Join Date: May 2015
Posts: 2
Default

402 Application is not properly installed [Ecwid External App API]


The error comes up every time when I want to use my token to access any features, even when I install the app in my devices.

Also, is there any Ecwid App Control Panel for the API as I cannot change redirect url or application title, etc.
  #2  
Old 03-10-2016, 05:09 PM
Daria Sh.'s Avatar
Daria Sh. Daria Sh. is offline
Ecwid Team
 
Join Date: Feb 2015
Posts: 767
Default

Quote:
Originally Posted by Keita @ CIA View Post
The error comes up every time when I want to use my token to access any features, even when I install the app in my devices.

Also, is there any Ecwid App Control Panel for the API as I cannot change redirect url or application title, etc.
Hi,

Thank you for contacting us.

Can you please explain which exactly App you are trying to install?

Hope to hear from you. Thanks.
__________________
Daria
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.
  #3  
Old 03-11-2016, 06:41 AM
Keita @ CIA's Avatar
Keita @ CIA Keita @ CIA is offline
Junior Member
 
Join Date: May 2015
Posts: 2
Default

Sorry for confusing you, I am trying to use Ecwid API in my own custom app and it has the error mentioned at the title, therefore I tried to install my own app into the device which still doesn't solve the issue.
  #4  
Old 03-18-2016, 09:06 AM
Cyril D's Avatar
Cyril D Cyril D is offline
Ecwid Team
 
Join Date: Feb 2015
Location: Ecwid HQ
Posts: 530
Default

Hello there,

I'm terribly sorry for the delayed reply!
Quote:
Originally Posted by Keita @ CIA View Post
402 Application is not properly installed
In most cases, when you get such an error, it means that you're trying to access the API using an account with the free subscription and the API functionality's available only for accounts on paid plans. I've checked your account with the store ID 7083807 and see that it's on the Free plan. To solve the issue and be able to utilize the Ecwid API, you should upgrade the account to any paid plan. Since you've registered the account within our partners, Wix, it means that you should switch the account to the Premium plan.

In case you were trying to access the API using a paid account, please let me know its store ID (you can see it on the bottom left of the Ecwid control panel) and we'll sort it out.

Hope to hear from you soon!
__________________
Cyril D.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
api, external app

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:58 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.