The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 01-17-2012, 11:24 AM
jamie.bainbridge's Avatar
jamie.bainbridge is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Wink


I have a wordpress theme www.jckmovies.com but for some reason my products and everything are all over the place can anybody help heres a link to the problem http://www.jckmovies.com/?page_id=35...=0&sort=normal

Last edited by Eugene Rimmer; 01-17-2012 at 12:03 PM. Reason: Please, do not doublepost.
  #2  
Old 01-17-2012, 01:16 PM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

I have inspected your store.

The misbehavior in question caused by your WP theme called 'multidesign' and the use of a custom .pageSlide() function in it. That function wraps the whole page body with an additional element, such wrapping re-executes all the scripts in the body of the page, and hence you get 2 sets of Ecwid widgets on the page. Basically, using that .pageSlide() function in its current for is incompatible with Ecwid widgets. Since only 1 Ecwid product browser can be active on a page, the last one that is being added becomes visible, so you see 2 category widgets and one product browser (another one is forced to be invisible).

The most correct way to fix it is to get rid of .pageSlide() function inside that page or on the website at all. The exact code that does call that function looks like this:
Code:
<script> 
$("#allpage-login-top").pageSlide({ width: "334px", direction: "left"});
$("#allpage-signup-top").pageSlide({ width: "334px", direction: "right" });
$("#allpage-search-top").pageSlide({ width: "350px", direction: "left", modal: true });
$("#homepage-login-button").pageSlide({ width: "350px", direction: "left" });
$("#homepage-signup-button").pageSlide({ width: "350px", direction: "right" });
</script>
Most probably you can find it in one of the files of your current WP theme. To prevent it spoiling your shop page you can possibly remove that code, but this will remove the effect of the Login, Signup, Connect and Search buttons - they will stop working.

So, a possible workaround instead of removing that function call would be to include a special code directly after the Ecwid code into your store page. This code disallows adding any more Ecwid widgets into the page, so there won't be any duplicates. The code reads as:
Code:
<script>window.xAddWidget = function() { return false;};</script>
It should be added into the source of your shop page in WordPress (WP Admin → Pages, select your page and click Edit beneath it, then make sure to switch editor to HTML mode with a tab on top of editor). Make sure the code is preserved as is, a one line; it is best to append it to the end of the line where existing Ecwid code ends, without a newline. With this workaround code you will have a correct set of Ecwid widgets and the effects on the Login, Signup, Connect and Search buttons still working.
  #3  
Old 01-17-2012, 04:27 PM
jamie.bainbridge's Avatar
jamie.bainbridge jamie.bainbridge is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Default

right, i will add this code and see what happens, i will keep you posted if it works or not., its just obviously i want all my images and everything showing on my website so lets see what happens.
  #4  
Old 01-17-2012, 04:37 PM
jamie.bainbridge's Avatar
jamie.bainbridge jamie.bainbridge is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Default

Hi that seems to have worked perfect, now if you have alook at this link http://www.jckmovies.com/?page_id=35...=0&sort=normal you will see all the dvd categoies at the top just keep going along is there any way to cut this into 2 or 3 rows or remove the top bits completley.
  #5  
Old 01-17-2012, 04:57 PM
jamie.bainbridge's Avatar
jamie.bainbridge jamie.bainbridge is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Default

Right i've managed to sort it out, i just deleted [ecwid_categories] and now it looks alright, Will this cause any problems with the ecwid plugin now that i've removed that bit heres a link http://www.jckmovies.com/?page_id=3511#ecwid:category=2067150&mode=category &offset=0&sort=normal
  #6  
Old 01-17-2012, 05:48 PM
Eugene Rimmer's Avatar
Eugene Rimmer Eugene Rimmer is offline
Senior Member
 
Join Date: Jan 2011
Location: Ecwid headquarters
Posts: 7,765
Default

Quote:
Originally Posted by jamie.bainbridge View Post
Right i've managed to sort it out, i just deleted [ecwid_categories] and now it looks alright, Will this cause any problems with the ecwid plugin now that i've removed that bit heres a link http://www.jckmovies.com/?page_id=3511#ecwid:category=2067150&mode=category &offset=0&sort=normal
That will not cause any problems to Ecwid, but you could just disable the categories in your WP Admin → Settings → Ecwid shopping cart instead of editing the page code to hide the categories widget.
  #7  
Old 02-17-2012, 12:55 PM
jamie.bainbridge's Avatar
jamie.bainbridge jamie.bainbridge is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Default

hi we are currently creating a mobile app for our wordpress site, is there any way to incorporate this into our app at all.

jamie
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
ecwid, theme, wordpress, wordpress theme

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:15 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.