The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 12-10-2014, 10:15 PM
Samantha Lunsford's Avatar
Samantha Lunsford is offline
 
Join Date: Dec 2014
Posts: 3
Default

Odd space before the header on my store


I'm having an issue with my store page. It adds a weird space before my header.

When I'm logged on, the admin bar sometimes covers this space up, but when not logged on, it just shows my background color.

How can I remove this space?

Here is the link to the store: http://vcheckglobal.com/online-business

  #2  
Old 12-15-2014, 05:06 PM
enot's Avatar
enot enot is offline
 
Join Date: Oct 2014
Posts: 499
Default

Quote:
Originally Posted by Samantha Lunsford View Post
I'm having an issue with my store page. It adds a weird space before my header.

When I'm logged on, the admin bar sometimes covers this space up, but when not logged on, it just shows my background color.

How can I remove this space?

Here is the link to the store: http://vcheckglobal.com/online-business

Hello!

I’ve followed the link you’ve provided, but I’m getting “page not found 404” error there: http://monosnap.com/image/RbyJ1U6SLQ...x1MU1UNKEGkpz#
Neither could I find the page from the screenshot anywhere else.

Still, troubleshooting in this case would require me to examine the page, and without it I’m afraid I couldn’t offer anything but guesses, which is not good enough.
So, please provide the link to the exact page where this issue can be seen, so I could take a thorough look at it.
  #3  
Old 12-15-2014, 05:44 PM
Samantha Lunsford's Avatar
Samantha Lunsford Samantha Lunsford is offline
 
Join Date: Dec 2014
Posts: 3
Default

Sorry about that, I had set the page to private. The link should be working now: http://vcheckglobal.com/online-business.

It seems to only be happening after the store loads.

Let me know if you need anything else.

Thank you!
  #4  
Old 12-23-2014, 06:14 PM
enot's Avatar
enot enot is offline
 
Join Date: Oct 2014
Posts: 499
Default

Hello!

Sorry for keeping you waiting. I’ve taken some time to investigate the issue, and actually here’s what I’ve found:

In this case the issue lies with the layout of all the pages, actually: on all the pages <head> part abruptly ends, and <body> part starts, and only after that all the “title”,“meta”, and other such parts go.

So, when a browser starts parsing the page, it encounters an error, and considers that this is the spot where <body> should begin. The difference with the page where Ecwid is located is visible because Ecwid, after loading, finds what it thinks to be the beginning of <body>, and adds its element there. Also, you can notice, that while such issue is visible in Chrome and Safari browsers, Firefox ignores it, and the page there is displayed as it should, due to a bit different parsing of the page.

So, in practical terms: since the layout of the theme that you are using is causing this issue, I can suggest either considering switching to some other theme. Or, provided you have the time and desire, edit the <head> part of the theme you are using: for example, there are several self-closing tags (that shouldn’t be self-closing, like “meta”) that could be causing this issue. Here’s an article describing how it should look: http://www.w3schools.com/html/html_head.asp
And here you can see an example from WordPress: http://codex.wordpress.org/Theme_Dev...8header.php.29
  #5  
Old 12-23-2014, 11:43 PM
Samantha Lunsford's Avatar
Samantha Lunsford Samantha Lunsford is offline
 
Join Date: Dec 2014
Posts: 3
Default

Thank you so much. I managed to find the problem in the header file and I fixed it using Notepad ++. I probably wouldn't have found the issue without your input.

Thank you again!
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
blank space, header, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:32 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.