The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 12-15-2015, 03:01 PM
Vintage Rocks's Avatar
Vintage Rocks is offline
 
Join Date: Oct 2014
Posts: 5
Default

Store takes minutes to load with WP plug-in


I've just installed the Ecwid plugin on my Wordpress site and it seems to take an age to load at my end.

Is there something that I've done wrong?

I've also added code onto my front page to display my paint product but the shopping bag doesn't work ... maybe because it's outside of the container?!
  #2  
Old 12-16-2015, 07:15 AM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Quote:
Originally Posted by Vintage Rocks View Post
I've just installed the Ecwid plugin on my Wordpress site and it seems to take an age to load at my end.

Is there something that I've done wrong?

I've also added code onto my front page to display my paint product but the shopping bag doesn't work ... maybe because it's outside of the container?!
Hello,

Thanks a lot for reaching us out!

We are very sorry you have faced the issue. Can you please provide us with a link to your Wordpress site so that we could look into it?

Thank you!
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
  #3  
Old 12-19-2015, 03:49 PM
Vintage Rocks's Avatar
Vintage Rocks Vintage Rocks is offline
 
Join Date: Oct 2014
Posts: 5
Default

Thanks Clara

It's www.vintagerocksinteriors.com
  #4  
Old 12-22-2015, 06:02 AM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Hello,

Thanks a lot for providing me with a link!

I have checked your site and see that there are two product browsers installed there: http://take.ms/pSRQR

Can you please remove Ecwid from your site and them re-embed it following the instructions here: http://help.ecwid.com/customer/en/po...-downloadable-

As for the paint product on your main page, please describe how you add the product there so that we could help you sole the issue.

Thank you!
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
  #5  
Old 12-22-2015, 12:10 PM
Vintage Rocks's Avatar
Vintage Rocks Vintage Rocks is offline
 
Join Date: Oct 2014
Posts: 5
Default

I have reinstalled the plug in and it is still taking ages to load.

On the front page I inserted the following code ...

<div class="ecwid ecwid-SingleProduct ecwid-Product ecwid-Product-47154198" style="text-align: justify;" itemscope="" itemtype="http://schema.org/Product" data-single-product-id="47154198">
<div itemprop="image"></div>
<div class="ecwid-title" itemprop="name"></div>
<div itemscope="" itemtype="http://schema.org/Offer" itemprop="offers">
<div class="ecwid-productBrowser-price ecwid-price" itemprop="price"></div>
</div>
<div customprop="options"></div>
<div customprop="addtobag"></div>
</div>
<p style="text-align: justify;"><script src="https://app.ecwid.com/script.js?5554064&amp;data_platform=singleproduct" type="text/javascript" charset="utf-8"></script><script type="text/javascript">// <![CDATA[
xSingleProduct()
// ]]></script></p>
  #6  
Old 12-28-2015, 07:11 PM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Quote:
Originally Posted by Vintage Rocks View Post
I have reinstalled the plug in and it is still taking ages to load.

On the front page I inserted the following code ...

<div class="ecwid ecwid-SingleProduct ecwid-Product ecwid-Product-47154198" style="text-align: justify;" itemscope="" itemtype="http://schema.org/Product" data-single-product-id="47154198">
<div itemprop="image"></div>
<div class="ecwid-title" itemprop="name"></div>
<div itemscope="" itemtype="http://schema.org/Offer" itemprop="offers">
<div class="ecwid-productBrowser-price ecwid-price" itemprop="price"></div>
</div>
<div customprop="options"></div>
<div customprop="addtobag"></div>
</div>
<p style="text-align: justify;"><script src="https://app.ecwid.com/script.js?5554064&amp;data_platform=singleproduct" type="text/javascript" charset="utf-8"></script><script type="text/javascript">// <![CDATA[
xSingleProduct()
// ]]></script></p>
Hello,

I am very sorry for the delay in replying.

I have checked your site again and see that the reason of it loading slowly is in the large images that are located in the footer of your site, please see the screenshot: http://take.ms/TNpZB They have large volume (in total about 56 Mb) and slow down the site loading. Please note that Ecwid starts loading only after all other elements on the page are loaded, so it waits after all these images load and shows only after that.

I would suggest to optimize these pictures and make them smaller to make the site load faster. I would also recommend not to use so many pictures in the footer.

As for the Single Product widget, please let me clarify the issue concerning adding single product widgets to Wordpress websites using the Embed Product code from Ecwid Control Panel.

As you mentioned, they seem to be not working in Wordpress.

The reason is that TinyMCE WYSIWYG editor, which is used in Wordpress corrupts microdata markup that is used in single product widget code, once you switch to the visual editor. That's a problem indeed, and we are looking for a way to work it around.

Ecwid plugin for Wordpress provides an ability to add single product widgets with the help of short codes.

Please find the instruction here: https://help.ecwid.com/customer/en/p...orpostofmysite

We'll definitely consider making this ability more noticeable in plugin's interface.

Hope that it helps. Should you have any further questions, please feel free to ask.

Thanks!
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
css, css and site integration, css basket responsive, plugin, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:32 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.