The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 01-18-2015, 08:59 PM
Robert Talbert's Avatar
Robert Talbert is offline
Junior Member
 
Join Date: Jan 2015
Location: Gaithersburg, Maryland USA
Posts: 7
Default

Default Category and MUSE Widget


I am using the MUSE eqwid widget which seems to work great EXCEPT I can not get the default category feature to work. I think I have entered the category ID correctly but when I go to my store site, the first thing I see is the categories under the horizontal tab which lists the categories. What I want to see is a list of the products in the default category.

site: artcampmontgomery.com/register.html
store id: 6399212
default category id:12014227

According the eqwid help info on this subject quoted below, I should be able to do exactly what I am trying to do (but it is not working):

Use #1:
Instead of showing the list of categories as big icons, you can have your store open a particular category by default, and resort to using the categories widget for navigating the categories. This is particularly useful if you don't have icons for categories.

Thanks in advance for any help,

Rob Talbert
Washington DC
  #2  
Old 01-19-2015, 01:11 PM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Dear Robert,

Thanks a lot for your message!

Yes, you are absolutely right, the default category option lets you to have your store open a certain category by default. Please refer to an article from our help center for more information: http://help.ecwid.com/customer/portal/articles/1155753

I have inspected your store and seen that you have embedded the script for the default category:

Code:
<div> <script type='text/javascript' src='http://app.ecwid.com/script.js?STORE_ID'></script> <script type='text/javascript'>  xProductBrowser("categoriesPerRow=3","views=grid(3,3) list(10) table(20)","categoryView=grid","searchView=list","style=","defaultCategoryId=CATEGORY_ID"); </script> </div>
And there is a slight error in this script on your page - there is a space before the number that represents the category ID ("defaultCategoryId=_12014227"). Please remove this space and the default category option will work fine - the products from this category will be shown on your store page by default.

Please let us know if you have further questions or need help in setting your store, it is my pleasure to be of assistance.
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
  #3  
Old 01-20-2015, 12:43 PM
Robert Talbert's Avatar
Robert Talbert Robert Talbert is offline
Junior Member
 
Join Date: Jan 2015
Location: Gaithersburg, Maryland USA
Posts: 7
Default

Thanks very much. I noticed that the MUSE-Theme for ecwid has a single space embedded in the default category field, so when you paste the category number in it applies it AFTER the space. I imagine that is a little error that MUSE-Themes people should fix because I am quite certain it trips up many. Fixing this fixed my problem.

However, now I notice after working more on my store yesterday, that I have the same problem again, although this time it is not the space. Not sure what I did to break it. Debugging this is a bit like searching for a needle in a hay stack - I don't know where to begin other than changing things and seeing if that solves my problem. I deleted the widget and re-added it but that did not solve it.
  #4  
Old 01-20-2015, 03:57 PM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Dear Robert,

Thanks a lot for your reply!

Unfortunately, I cannot inspect your store as it is closed for maintenance at the moment. Could you please open it for some time so that we could check it for you?

Thank you!

Last edited by Clara K; 01-21-2015 at 06:55 AM.
  #5  
Old 01-21-2015, 07:05 AM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Dear Robert,

Thanks a lot for opening the store!

As far as I can see, the default category is displayed fine now.

I believe you have fixed it by changing the category ID in the code for showing a default category as there was an ID of a non-existing category there.

As for the MUSE-theme for Ecwid with a extra single space in the default category field, could you please provide me with a link to this theme so that I could check it?

Please let me know if you have further questions, it is my pleasure to help.

Thank you!
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
  #6  
Old 01-21-2015, 09:32 AM
Robert Talbert's Avatar
Robert Talbert Robert Talbert is offline
Junior Member
 
Join Date: Jan 2015
Location: Gaithersburg, Maryland USA
Posts: 7
Default

Yes, sorry, I found my error last night. The default category is working fine.
The Following User Says Thank You to Robert Talbert For This Useful Post:
Clara K (01-21-2015)
  #7  
Old 03-22-2015, 08:47 PM
JoAnne Sabir's Avatar
JoAnne Sabir JoAnne Sabir is offline
 
Join Date: Mar 2015
Posts: 1
Default

Hello, My MUSE-THEME Ecwid widget is not working at all. In muse it appears to work fine andmy categories appear. However, when I publish it to my site, juicekitchen.businesscatalyst.com it just shows the mock store. Any help? I need to reach a deadline to publish this site soon for a client. Thank you!
  #8  
Old 03-23-2015, 08:25 AM
Sergio87's Avatar
Sergio87 Sergio87 is offline
Ecwid Team
 
Join Date: Mar 2014
Posts: 1,512
Default

Quote:
Originally Posted by JoAnne Sabir View Post
Hello, My MUSE-THEME Ecwid widget is not working at all. In muse it appears to work fine andmy categories appear. However, when I publish it to my site, juicekitchen.businesscatalyst.com it just shows the mock store. Any help? I need to reach a deadline to publish this site soon for a client. Thank you!
Hello JoAnne,

I am very sorry to hear you have faced this issue on your website.

I have just inspected it here http://juicekitchen.businesscatalyst.com and as far as I can see it wrks great. I am able to explore your storefront, put items in my shopping bag and proceed to checkout.

Here is my screenshot:

Can you confirm if the problem still exists? And if yes - what steps I should make to reproduce the issue?

Look forward to hearing from you.
__________________
Sergey G., Ecwid Team
------------------
Welcome to our Help Center with a lot of answers and tips!
  #9  
Old 02-29-2016, 09:14 PM
Lucky9436's Avatar
Lucky9436 Lucky9436 is offline
Junior Member
 
Join Date: Aug 2015
Posts: 7
Default

Hello. I am using Muse to get our online store in our web site. roselynrecipe.com/testbed/ The amount of space before the products display is becoming a problem. I noticed in the juicekitchen site that some of the widgets i am having trouble with are all grouped together, like the "Sign In | Favorites Shopping Bag" area. How do I do that?

Also, I had to delete our categories so the products would all display on the first store page, which works fine. Am I supposed to change the Muse ecwid widget control "Categories per row" to zero? It is set to 3 now.

Thank you.

Lucky
  #10  
Old 03-22-2016, 04:53 PM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Quote:
Originally Posted by Lucky9436 View Post
Hello. I am using Muse to get our online store in our web site. roselynrecipe.com/testbed/ The amount of space before the products display is becoming a problem. I noticed in the juicekitchen site that some of the widgets i am having trouble with are all grouped together, like the "Sign In | Favorites Shopping Bag" area. How do I do that?

Also, I had to delete our categories so the products would all display on the first store page, which works fine. Am I supposed to change the Muse ecwid widget control "Categories per row" to zero? It is set to 3 now.

Thank you.

Lucky
Hi Lucky,

I apologize for the delay in replying.

As far as I can see, Wendy has already replied to your question regarding aligning the elements here: https://www.ecwid.com/forums/showthr...t=36620&page=2

As for the number of categories displayed, as you have no categories (i.e. all of your products are added to the root category), it does not actually matter what number you put in the widgets settings for the number of categories to show.

Thank you!
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:12 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.