The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 08-03-2017, 02:11 PM
Molly Luksik's Avatar
Molly Luksik Molly Luksik is offline
 
Join Date: Aug 2017
Posts: 1
Default pay now button unresponsive

The pay now button is unresponsive to my customers. Nothing is happening when they click it.

http://www.cmballet.org/online-store
The Following User Says Thank You to Molly Luksik For This Useful Post:
  #2  
Old 08-04-2017, 10:44 AM
Elaine V's Avatar
Elaine V Elaine V is offline
Ecwid Team
 
Join Date: Sep 2016
Posts: 93
Default

Hi,

I have checked your site and the checkout portion works fine for me. As soon as valid credit card details are entered (credit card number, secure code, expiration date and cardholder's name), the Pay Now button gets activate and allows to proceed. Are you entering real credit card details in the credit card form or some random numbers?

If you'd like to test it, you can use test credit card numbers. Also, as you know, different credit card types require different number of digits to be entered for Security code (or "CVC" or "CVV") - please pay attention to that, too, when making a test as well as fill out all the other fields in the credit card form.

If there is still an issue with some real credit card, please let me know the type of the credit card you're entering that doesn't make the Pay Now button active. Thank you.
__________________
Elaine,
Ecwid Team
The Following User Says Thank You to Elaine V For This Useful Post:
  #3  
Old 01-08-2018, 09:00 PM
Patrik Banas's Avatar
Patrik Banas Patrik Banas is offline
 
Join Date: Jan 2018
Posts: 1
Default

Hi Elaine,

I have a same issue. My "Buy Now" button, generated in the product pageis unresponsive, when I enter it on my website. I am using wix and added it as "HTML code". Payment button will show "v" check sign, but after nothing happens. I was expecting it will take client to cart site or something. But like this nothing happens...
Thanks for clarification too!... And thanks Molly for opening this thread...

https://www.pixien.eu/stripe-testing
The Following User Says Thank You to Patrik Banas For This Useful Post:
  #4  
Old 01-08-2019, 02:29 PM
Charlie Morrison's Avatar
Charlie Morrison Charlie Morrison is offline
 
Join Date: Aug 2015
Posts: 1
Default

URGENT - Pay Now button not working!
Hi there, we've had customers try to purchase our products today on our website that explain that our 'Pay Now' button isn't working?! We've tried ourselves and they definitely are not working! We have a huge event in the next couple of hours that we MUST have our Ecwid payment service working for... can someone please look into this ASAP?!?!?!?!?!?
We're so worried and anxious and we're loosing business as a result.
  #5  
Old 01-08-2019, 03:27 PM
Elaine V's Avatar
Elaine V Elaine V is offline
Ecwid Team
 
Join Date: Sep 2016
Posts: 93
Default

Hi Charlie,

I've checked your WEMC online store's checkout and so far can't reproduce the issue on my end. I've tried to place order there using a test credit card number and received the following correct response from Stripe: "Unable to perform charge. Your card was declined. Your request was in live mode, but used a known test card." Then I've entered a real credit card number that had not enough funds on it to pay for the order in full, clicked on Pay Now button and got the following expected response from Stripe for such cases: "Unable to perform charge.Your card has insufficient funds."

Please provide more details on where and how you see the issue:
1) What message from payment system you see after clicking on Pay Now button
2) What browser and operating system you are using? This information can be copied from our diagnostic page: https://www.ecwid.com/internet
3) Do you see the same issue if you use a different browser?

You can create a $1 product, mark it as the one that doesn't require shipping, hide it in the storefront by placing this product in enabled subcategory with a disabled category and place a test order.

This information will help us reproduce and troubleshoot the issue. Thank you.
__________________
Elaine,
Ecwid Team
  #6  
Old 01-13-2019, 03:19 PM
David Long4's Avatar
David Long4 David Long4 is offline
 
Join Date: Jan 2019
Posts: 4
Default

What I've noticed using Chrome browser, when I clicked on a test 'Buy It Now' button, and nothing seemed to happen, I then noticed a small bag icon at the lower right corner of the browser, with the number '5' on it. It was a minimized pop-up, and there were 5 instances of the pop-up to then see.

I'm new to Chrome, so am unsure if this is a feature of this browser. I write this in case it helps others discover the 'Buy it Now' button is somewhat working.

Update: The same bag icon appears on FireFox.

Update: I use Joomla, and the custom HTML module probably accounts for this minimized pop-up behavior.

Last edited by David Long4; 01-13-2019 at 03:46 PM.
  #7  
Old 01-14-2019, 09:31 AM
Kenga Ecwid's Avatar
Kenga Ecwid Kenga Ecwid is offline
Ecwid Team
 
Join Date: Jun 2016
Posts: 109
Default

Quote:
Originally Posted by David Long4 View Post
What I've noticed using Chrome browser, when I clicked on a test 'Buy It Now' button, and nothing seemed to happen, I then noticed a small bag icon at the lower right corner of the browser, with the number '5' on it. It was a minimized pop-up, and there were 5 instances of the pop-up to then see.

I'm new to Chrome, so am unsure if this is a feature of this browser. I write this in case it helps others discover the 'Buy it Now' button is somewhat working.

Update: The same bag icon appears on FireFox.

Update: I use Joomla, and the custom HTML module probably accounts for this minimized pop-up behavior.
Hi David!

This is Kenga from Ecwid.
Thanks for your message.

I'm sorry to know that the 'Buy it Now' button doesn't properly work for you.

As I see, you specified this link as your Ecwid Storefront url. To my regret, I can't open this page, it returns the 403 error.

So, I decided to check how your Ecwid Starter Site works:

- I put an item to my bag
- on the Payment information page, I entered the test credit card details
- I clicked the Pay $80.65 button to confirm the payment
- As I result, I got the card_declined error message in the upper right corner. That's the expected error because I used the test credit card details. Check the video:
https://monosnap.com/file/ngtEQ9kb9w...k1YbYfVOUTZaWD

As you see, the Pay $80.65 button is active.

In order to check what happens on your Joomla site, we need to get access to the published page with Ecwid store. Send us the link to the page with Ecwid on your Joomla site.

We'd appreciate if you detail what steps we should perform to reproduce the same issue as you.

Also, send us a video or a screenshot of the problem.

This information will help us to troubleshoot the issue.

Always happy to hear from you!
__________________
Kenga

Ecwid team
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:08 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.