The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 05-25-2018, 03:39 PM
Boise Brand's Avatar
Boise Brand is offline
Junior Member
 
Join Date: Oct 2017
Posts: 1
Question

Domain Connection Not Private


Hi,
I have been working on my storefront for a couple months and have finally purchased a domain to connect to my starter site. I followed the instructions from your website adding an A and CNAME in my domain settings and have copied the address to your site. I have spoken with GoDaddy's customer service who told me that this error is not on their end but rather an issue that my site is not secure and therefor Google doesn't trust it and causes this error. I have read through Ecwid forums and Q&As and know that all parts of Ecwid are secure and so I do not think I should be having this issue. If I do not include https in my domain and rather just http, it tells me that the storefront is coming soon but still not secure. Please help.
Thanks,
Cody
https://boisebrandapparel.com

Last edited by Boise Brand; 05-25-2018 at 05:41 PM.
  #2  
Old 05-28-2018, 10:15 AM
Edward M.'s Avatar
Edward M. Edward M. is offline
Ecwid Team
 
Join Date: Dec 2016
Posts: 261
Default

Hi,

I'm Edward from Ecwid Team.

Thank you for the message. I'll be happy to help you.

As I can see, you try to connect the domain boisebrandapparel.com to your Ecwid Starter site, a free one-page website with your store.

Firstly, it's important to note that you can use your own domain with the Starter site on the Ecwid paid plans only. At the moment, your account is on the Free plan, so you cannot connect your own domain with the Starter site. Though, on the Free plan, you can use a subdomain that looks like mystore.ecwid.com

Please see the screenshot: http://take.ms/zB6mi

Here's the article with more details about changing the URL of your Starter site: https://support.ecwid.com/hc/en-us/a...dmystartersite

Secondly, all Ecwid Starter Sites are run on a secure SSL connection by default. For instance, your Starter site is available at https://boisebrand.ecwid.com/ and it runs on a secure protocol.

Thirdly, when connecting your own domain, you need to follow the steps described in the article at https://support.ecwid.com/hc/en-us/a...d-Starter-Site

Important note: make sure that you only have one A-record for your domain — the A-record that points to the Ecwid Starter site (34.193.83.23). If you have any other A-records, please delete them.

Summing it all up, to use your own domain, you need to be subscribed to any Ecwid paid plan and have the settings configured just as instructions state. After that, your Starter site will work under your own URL with the SSL certificate (secure connection).

I hope this information is helpful.

If you have any questions — feel free to ask.
__________________
Ecwid Customer Care Team
More tips and hints on Ecwid use in Ecwid Help Center
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
connection, domain, error, secure

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:28 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.