The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 08-13-2014, 04:44 PM
John C's Avatar
John C is offline
Member
 
Join Date: Jun 2011
Posts: 71
Default

Trouble getting Google AJAX indexing to work for my store


I have posted this problem twice. I have been an Ecwid customer for years. I would appreciate it if an Ecwid team member could look at this and reply.

I cannot get my store to generate the Google-friendly links using the Ajax indexing method described here:

http://kb.ecwid.com/w/page/62638683/...0Ecwid%20store

My store page (stripped down for testing purposes) is at this link:

https://craigheadleather.com/testphpstore.php

I see <meta name="fragment" content="!" /> in <head> so I know test #1 is working. However, I do not see the store category URLs when I add ?&_escaped_fragment_= to the store URL. Therefore I believe test#2 is failing.

I have contacted the hosting company and they claim both php and curl are enabled.

This link shows php and cURL settings for my server:

https://craigheadleather.com/phpinfo.php

Do you see anything I'm doing incorrectly? What do I need to do to make this work?

Thank you,
John
  #2  
Old 08-13-2014, 07:11 PM
Thematizr.com's Avatar
Thematizr.com Thematizr.com is offline
Webpartner
 
Join Date: Jul 2012
Posts: 379
Default

You need to check with your hosting company for any PHP errors in the webserver log mentioning the PHP file in question. Clearly, something goes wrong on the server but it is obscure to everyone since your PHP errors may be suppressed in the configuration of your server. If there are any errors, let us know.
__________________
Check out our latest ready-made designs for Ecwid:

Termion | Helata | Martina

Get 1 year of access to all our current and future themes.

Follow us on Twitter: @thematizr
The Following 2 Users Say Thank You to Thematizr.com For This Useful Post:
Liza P (08-21-2014), Sergio87 (08-14-2014)
  #3  
Old 08-13-2014, 08:00 PM
John C's Avatar
John C John C is offline
Member
 
Join Date: Jun 2011
Posts: 71
Default

Thank you for your reply. The error below appears whenever I open the store page:

[13-Aug-2014 13:08:16 America/Denver] PHP Notice: Undefined variable: ecwid_html_index in /home1/craighea/public_html/testphpstore.php on line 32

I tweaked the path to ecwid_ajax_indexing.php and that fixed it.

Thanks for setting me on the right path (ha, ha)
John

Last edited by John C; 08-13-2014 at 08:30 PM. Reason: fixed problem after original post
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
ajax indexing, indexing categories, product api, seo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:30 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.