The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 01-21-2013, 09:36 PM
ellie's Avatar
ellie is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Question

Problem with Shipping?


Hello,

I'm setting up Ecwid on my site, I don't have it online yet, I'm designing in Freeway and viewing in safari. I chose us, canada, and eu for shipping destinations and I set up usps with usa as the destination and ny only for sales tax. I can add products into my cart and see a possible tax now, but when I tried to purchase a product as a test, I got a message saying we don't ship to that destination or something... how is that possible? I'm in ny and I'm using my address to ship to.

Have I done something wrong here? Is there something else I need to do to set up shipping? I watched a video but there doesn't seem to be any discussion about that. Someone just said she selected Australia and a zone there since she shipped there a lot, but that it was basically all set up already with use, canada, eu etc.

Thanks!
  #2  
Old 01-22-2013, 07:46 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by ellie View Post
Hello,

I'm setting up Ecwid on my site, I don't have it online yet, I'm designing in Freeway and viewing in safari. I chose us, canada, and eu for shipping destinations and I set up usps with usa as the destination and ny only for sales tax. I can add products into my cart and see a possible tax now, but when I tried to purchase a product as a test, I got a message saying we don't ship to that destination or something... how is that possible? I'm in ny and I'm using my address to ship to.

Have I done something wrong here? Is there something else I need to do to set up shipping? I watched a video but there doesn't seem to be any discussion about that. Someone just said she selected Australia and a zone there since she shipped there a lot, but that it was basically all set up already with use, canada, eu etc.

Thanks!
Hi,

I've examined your Ecwid store settings. 'We do not ship to this location' error appears because of the shipping settings.
You setup your store to receive online shipping rates from USPS. Most likely your USPS account is in test mode. You can check it in your Ecwid control panel, System Settings -> Shipping -> click 'Carrier-calculated' -> 'Account Details', button 'Test method'. Ecwid will connect to USPS to test the settings. If it's configured properly, you'll see a message 'Test succeeded'. If your USPS account is in test mode, you'll receive a warning about it there.
Please, refer to this article for the instructions how to solve the issue:
I've enabled USPS but still cannot see the rates.

Also the shipping method is configured for zone 'USA'. This zone includes three countries: United States, United States Minor Outlying Islands, and Virgin Islands, U.S., and one state "United States: New York".
Ecwid determines customer's zone by country, then state, then zip code. If the zone has a state, this state must be in the submitted shipping address.
Thus your zone 'USA' covers only New York state. It means that the shipping will be calculated only for those customers who will submit US, New York in their shipping address.
If you want to ship to the other US states you need to change this destination zone 'USA':
- in Ecwid control panel, System Settings -> Zones, enter 'USA' zone
- under 'States' box, remove New York state
- click 'Save'.
After that zone 'USA' will cover all the three countries.

If you want to ship to Canada and Europe, you need to create shipping methods for these zones as well.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #3  
Old 01-23-2013, 02:48 AM
ellie's Avatar
ellie ellie is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Default

Thank you Svetlana,

I have contacted USPS to ask that my account be switched to live mode. As far as the shipping zone- I originally selected NY to try and add tax for that state only after reading a tutorial. So I guess I should simply delete NY state now and set up a whole zone for NY alone? I'm clear on what to do here.
Ellie
  #4  
Old 01-23-2013, 04:43 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by ellie View Post
Thank you Svetlana,

I have contacted USPS to ask that my account be switched to live mode. As far as the shipping zone- I originally selected NY to try and add tax for that state only after reading a tutorial. So I guess I should simply delete NY state now and set up a whole zone for NY alone? I'm clear on what to do here.
Ellie
Hi,

If you're going to have two different shippings to New York and to the other states (e.g., you want to ship within NY using local pickup, and to the other states - via USPS First-Class services), then you need to have the following two zones:
1. Country USA, States - New York
2. Country USA, States - all except for New York.
NOTE: Remember to add two shipping methods for each zone. If to take the above example, the methods will be: local pick-up for New York, and USPS online rates for the other states.

If you have one shipping method for all US states (e.g., USPS services to all directions), you need only USA zone. So you should just remove New York state from your current 'USA' zone.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #5  
Old 01-23-2013, 08:04 PM
ellie's Avatar
ellie ellie is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Default

Hi Lana,

I did all that and I think it is working... I figured out I have to add ny as a state in the zone ny for it only to charge taxes in NY state. I will see if everything works now, hopefully!

I set up two other shipping methods for Canada and Eu also.

I'm thinking about doing flat rate shipping also... but I'm not sure how to calculate approximates costs for what I ship for that.. is there a tutorial for that?

Thanks!

Ellie

Last edited by ellie; 01-23-2013 at 09:38 PM.
  #6  
Old 01-23-2013, 08:26 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by ellie View Post
Hi Lana,

I did all that and I think it is working... I figured out I have to add ny as a state in the zone ny for it only to charge taxes in NY state. I will see if everything works now, hopefully!

I set up two other shipping methods for Canada and Eu also.

I'm thinking about doing flat rate shipping also... but I'm not sure how to calculate aproximates costs for what I ship for that.. is there a tutorial for that?

Thanks!

Ellie
Hi,

Destination zones can be used for shipping methods and for taxes. At that you can assign different zones to shipping and tax.
As I see you want to apply the tax to New York only and assign USPS shipping method to the whole USA. In this case, you need two zones:

1. Country USA, States - New York
2. Country - USA

Then you will assign the first zone to the tax rate (in Ecwid control panel, System Settings -> Taxes), and the second one - to the shipping method (in System Settings -> Shipping).
As a result, customers from US, NY will receive the tax rate and this USPS shipping method. And customers from any other state won't be charged the tax rate.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
destination, ecwid, problem, shipping, test

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:46 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.