Thread Tools Display Modes
  #1  
Old 05-17-2020, 03:21 PM
Dan Willard1's Avatar
Dan Willard1 is offline
 
Join Date: Mar 2017
Posts: 1
Default

Store URLs not working after changing font in CSS Theme


My Ecwid store is around 4 years old and never had issues. A couple weeks ago, all of the font in my store randomally changed (hadn't even logged into Ecwid for a week prior). Ecwid never responded to my help request, so I decided to just create a new theme to change all font. Pretty simple and I used the code from the Ecwid cookbook to change all font family. Done and looked good.

Immediately after, I realized the URLs were not working. If I copy and paste a store URL into a browser, the page that comes up defaults to my storefront (however, the URL itself is correct - meaning that it is not defaulting to the storefront URL). If I then simply refresh the page, URL stays the same and the correct store page populates.

Example: www.fusion4x4.com, and then on the menu click "STEERING". The URL that comes up is correct, but it populates a storefront that I don't use. If you refresh the page, then it populates and URL stays the same.

This is a huge issue for me because I use Wix. So, the Wix menu is linked to the store page URLs. All of the menu links are correct (I double checked). Every single time, it is the same thing. Correct URL, but the page populates with the storefront and then if I refresh, the correct page populates.

For about an hour after this started, there were two URLs for every store page. The frist one that would show up was different. A standard Ecwid URL ends with a number "c1234567", but the first URL that would come up would be something like "c1234567/%normal/xxxxxxx%" something like that. There was a bunch of stuff after that is not usually there. Same deal, if I refresh, it went away and the correct page would populate. That is now gone, but the same issue persists.

Any help would be appreacieted is the Ecwid support team is out to lunch and I have not been able to get a response from them.

Thanks!
  #2  
Old 05-18-2020, 02:20 PM
Ksenia Avdonina's Avatar
Ksenia Avdonina Ksenia Avdonina is offline
Ecwid Team
 
Join Date: Jul 2019
Posts: 16
Default

Hello,
This is Xena, Ecwid Customer Care team. Thanks for reaching us out!

I'm sorry for the font issue. Yet, I'm glad to hear that it is resolved now.

Coming back to the menu links query, I'm so sorry for the issue with navigation links: our developers were notified about it and fixed it.

So category pages are now reachable from the site navigation menu. Just in case, I've recorded a video for you showing how your website operates now: https://ecwid.d.pr/QEaUzk


If you have any other questions, feel free to contact us.
__________________
Warmly,
Xena

Ecwid Customer Care team
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:04 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.