The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 05-05-2015, 01:37 PM
Gordon Bryant2's Avatar
Gordon Bryant2 is offline
Junior Member
 
Join Date: May 2015
Posts: 1
Default

Replacement "Continue Shopping" button not working


I have used the supplied code for replacing the button images, and they all worked except for the "Continue Shopping button, which won't work, and I can't figure out why.

The code I'm using is:
/* The "Continue Shopping" button in up state */
div.ecwid-ContinueShoppingButton-up, div.ecwid-ContinueShoppingButton-up-hovering, div.ecwid-ContinueShoppingButton-ie6-up, div.ecwid-ContinueShoppingButton-ie6-up-hovering {
background-image: url(http://i.imgur.com/PFHbDnz.png) no-repeat top center;
}
/* The "Continue Shopping" button in down state */
div.ecwid-ContinueShoppingButton-down, div.ecwid-ContinueShoppingButton-down-hovering, div.ecwid-ContinueShoppingButton-ie6-down, div.ecwid-ContinueShoppingButton-ie6-down-hovering {
background-image: url(http://i.imgur.com/PFHbDnz.png) no-repeat top center;
}
When I try to use that on my store (or more accurately, on a local offline test build of the store) the original continue shopping button appears, and looking in the chrome Inspector reveals that my style is underneath.



Disabling the first style (the original one) using the element inspector shows my new button, which then works correctly. I just want to get rid of the original one that is rendering on top.

Can anyone help?
  #2  
Old 05-06-2015, 04:26 AM
Maristany's Avatar
Maristany Maristany is offline
Senior Member
 
Join Date: Dec 2009
Posts: 419
Default

In the code you provided it says background instead of background-image, but it seems you're using the right code. The thing is, that first continue shopping button is around 350 lines inside your custom theme and is an image of the Beige Theme, maybe you activated it and you're adding your customizations there? If that's the case it'll work if you don't add many modifications, but can become very messy if you do.

Just a thought, hope this helps.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
css and site integration, custom button, error, themes

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:37 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.