The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 02-03-2017, 10:51 AM
MW Studio's Avatar
MW Studio is offline
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

Store not indexing on Google - integrated into Adobe Muse website


Hi there,

We are having a SEO problem with our Ecwid store which we have setup and added into one of our clients websites. The website is built in Adobe Muse and the store is integrated via the Adobe Muse/Ecwid widget:

http://alexandrawoodbespoke.co.uk/shop.html

Example product URL:

http://alexandrawoodbespoke.co.uk/sh...egory=20279248


The store has been in the website for nearly 4 months and as yet no products are appearing on Google and it seems nothing from the store has been indexed?

We have been reading the various posts about Ajax indexing (which we believe is now old?) and clean URL's (which we've struggled to get to work) so any help or advice would be greatly appreciated.

Thanks in advance,

Phil
mwstudio.uk
  #2  
Old 02-10-2017, 02:19 PM
John R Perry's Avatar
John R Perry John R Perry is offline
Webpartner
 
Join Date: Dec 2014
Posts: 79
Default

Hi there!

This guide will help you with activating clean URLs. It's what I'm using on my site and as you can see, every page is indexed.
The Following User Says Thank You to John R Perry For This Useful Post:
smartMart (03-13-2017)
  #3  
Old 02-10-2017, 02:33 PM
MW Studio's Avatar
MW Studio MW Studio is offline
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

Hi there,

Thanks for the reply and links - we will give this a try and report back....

We are currently using the Ecwid plugin by Muse Themes, I assume you recommend replacing this with the widget you offer?

Regards,
Phil
  #4  
Old 02-10-2017, 02:34 PM
John R Perry's Avatar
John R Perry John R Perry is offline
Webpartner
 
Join Date: Dec 2014
Posts: 79
Default

Yes. I don't believe their widget is capable of offering clean URLs yet.
  #5  
Old 02-10-2017, 02:36 PM
MW Studio's Avatar
MW Studio MW Studio is offline
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

OK, thank you. We will switch the widget and follow your steps above....

Phil
  #6  
Old 02-10-2017, 03:33 PM
John R Perry's Avatar
John R Perry John R Perry is offline
Webpartner
 
Join Date: Dec 2014
Posts: 79
Default

Let me know if you have any questions!
  #7  
Old 02-21-2017, 12:23 PM
John R Perry's Avatar
John R Perry John R Perry is offline
Webpartner
 
Join Date: Dec 2014
Posts: 79
Default

So awesome to hear! Thank you for the feedback!
  #8  
Old 02-21-2017, 12:23 PM
MW Studio's Avatar
MW Studio MW Studio is offline
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

Hi John,

I just wanted to say thank you for your help on this.

We removed the Muse Themes widget and installed your J-26 widget last week - following your clear installation steps - and am pleased to say the store is already indexing very well.

Hopefully this may help other Muse users, who are in the similar situation to which we were.

Much appreciated.
Phil
The Following 2 Users Say Thank You to MW Studio For This Useful Post:
John R Perry (03-13-2017), smartMart (03-13-2017)
  #9  
Old 03-13-2017, 09:11 AM
MW Studio's Avatar
MW Studio MW Studio is offline
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

Hi John,

Just following on from my emails the other week - I’m not sure if you got my response about the alternative or responsive layouts - but just wondered if you’ve had chance for anymore thoughts on our issue?

The website is built with an individual desktop and individual phone website.

Unfortunately a problem has now appeared - as soon as the ‘clean URL htaccess text’ (generated from your webpage https://www.j-26.com/resources/gener...rls/#generator) is put into the htaccess file - the phone pages either now fail to load, or mainly appear but with all formatting and css lost when the browser redirects the URL to the ‘phone’ files. We have currently deactivated the clean URL .htaccess file to keep the website visible.

The URL is….

http://www.alexandrawoodbespoke.co.uk

Any thoughts would be appreciated.

Thanks in advance,
Phil
  #10  
Old 03-13-2017, 04:13 PM
smartMart's Avatar
smartMart smartMart is offline
 
Join Date: Oct 2014
Posts: 278
Default

Quote:
Originally Posted by John R Perry View Post
My respect, John! Brilliant work and good results example.
The Following User Says Thank You to smartMart For This Useful Post:
John R Perry (03-13-2017)
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:47 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.