The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 11-13-2017, 07:04 PM
Child of Bast's Avatar
Child of Bast is offline
 
Join Date: Feb 2016
Posts: 4
Default

WP Storefront displaying "Sorry, the requested product is not available."


My last actions include duplicating a product and changing the storefront display to 3 columns rather than 2. I haven't had this problem before and everything else looks correct.

My other website where I run the same store with different products is working just fine.

Storefront: http://www.childofbast.com/services/

Thank you for your help!
The Following User Says Thank You to Child of Bast For This Useful Post:
  #2  
Old 11-13-2017, 07:46 PM
Child of Bast's Avatar
Child of Bast Child of Bast is offline
 
Join Date: Feb 2016
Posts: 4
Default

I fixed it by displaying root category, but I don't understand why the category won't show up. I should be able to display the category products instead of going to the root.
The Following User Says Thank You to Child of Bast For This Useful Post:
  #3  
Old 11-13-2017, 08:01 PM
Child of Bast's Avatar
Child of Bast Child of Bast is offline
 
Join Date: Feb 2016
Posts: 4
Default

I fixed everything. For those who find this topic in the future with the same problem, try this:
In the Text editor, the code displayed a default product ID that linked to the category ID. Delete that number and it will display the category correctly!
The Following 2 Users Say Thank You to Child of Bast For This Useful Post:
Давыдов Дмитрий (01-08-2018), Joseph Walker1 (05-31-2019)
  #4  
Old 11-20-2017, 02:25 PM
Matt Ecwid's Avatar
Matt Ecwid Matt Ecwid is offline
Ecwid Team
 
Join Date: Oct 2011
Posts: 4,947
Default

Hi,

This is Matt from the Ecwid team.

Sorry for the delayed response. We fixed this issue in the latest Wordpress plugin update. Please update your plugin to get this fixed. Now you can use the default category and/or the default product, everything should work fine.

I am sorry for the troubles caused by this.

Thanks,
__________________
Matt K
Ecwid Team

Ecwid Guide for Beginners

Ecwid Help Center

Ecwid video tutorials
The Following User Says Thank You to Matt Ecwid For This Useful Post:
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:51 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.