The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 12-05-2012, 04:59 PM
XpertSkills's Avatar
XpertSkills is offline
 
Join Date: Mar 2012
Posts: 2
Default

HTML tags interfering with CSV export


Hello

I am struggling to export my products to CSV. Everything works fine until I try to export the descriptions aswell.

I checked why and I believe it is the "false" delimeters that the HTML tags in the descriptions has. This results in the CSV file having spread all over the CSV file.

Is there any way that I can strip the HTML tags before export?

I also tried to use the API's to solve this issue but the "get products" function does not include the product descriptions.

Is it maybe possible to get an database dump in sql file or something to work around this?

Any Ideas?
  #2  
Old 12-05-2012, 05:33 PM
mkpsoftware's Avatar
mkpsoftware mkpsoftware is offline
 
Join Date: Dec 2011
Posts: 193
Default

Quote:
Originally Posted by XpertSkills View Post
Hello

I am struggling to export my products to CSV. Everything works fine until I try to export the descriptions aswell.

I checked why and I believe it is the "false" delimeters that the HTML tags in the descriptions has. This results in the CSV file having spread all over the CSV file.

Is there any way that I can strip the HTML tags before export?

I also tried to use the API's to solve this issue but the "get products" function does not include the product descriptions.

Is it maybe possible to get an database dump in sql file or something to work around this?

Any Ideas?
When using the API you must get the products then loop through each product to get the product detail. This detail will have the description.

HTH

Tim
The Following User Says Thank You to mkpsoftware For This Useful Post:
XpertSkills (12-05-2012)
  #3  
Old 12-05-2012, 06:48 PM
XpertSkills's Avatar
XpertSkills XpertSkills is offline
 
Join Date: Mar 2012
Posts: 2
Default

Thank you. I got this to work. I originally tried the loop script that you talked about but it didn't work because the execution time was exceeded all the time. I found out that you could increase the execution time of the script with "set_time_limit(0);".

You just insert that piece of code into your loop and your set to go.

Thank you
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
csv, export, html tags

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:16 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.