The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 12-17-2014, 03:13 PM
Polar's Avatar
Polar is offline
Junior Member
 
Join Date: Dec 2014
Posts: 5
Question


Hi,

I followed the instruction from your site : http://help.ecwid.com/customer/portal/articles/1171402

The player that you suggest works fine on PC based browsers, but not on Android and iOS. So I tested another solution. I installed a player on my web server, and when running it from a local page it works fine. The code is following: (can be placed entirely in the body):
HTML Code:
    <!-- start Audio.js -->
    <script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
    <script>
      audiojs.events.ready(function() {
        audiojs.createAll();
      });
    </script>
    <!-- end Audio.js -->
<audio src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3" preload="auto"> </audio>
However, when I enter the code in my ECWID product HTML page, after saving it looks different from the original, and the player won't show when loading the page in your browser.
HTML Code:
<!-- start Audio.js -->
<script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
<script type="text/javascript">// <![CDATA[ 
      audiojs.events.ready(function() {
        audiojs.createAll();
      });
// ]]></script>

<!-- end Audio.js --> <audio preload="auto" src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3"> </audio>
The direct link is: http://care4u.ecwid.com/#!/Selvhypno...egory=11696035

Please your advice.

I did some further testing. First I installed a fresh web page on another domain. From that page I called the remote js script and the remote mp3 from domain A. Worked OK.

Next test: I see that the html from ECWID is rewritten and parsed. I removed the lines :
HTML Code:
<script>
audiojs.events.ready(function() {
audiojs.createAll();
});
</script>
and made a seperate external js file of it. Now the html code looks like this:
HTML Code:
<script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
<script src="http://www.care4-u.no/js/audiojs/audiojs/external.js"></script>
<audio src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3" preload="auto"> </audio>
Still not working, but it works fine when running this from domain B. (calling the js and MP3 from domain A).

So there is something on your server that stops the player from showing. The html code (chrome>>inspect element) however is including the scripts and the audio tag.

Last edited by ___44326; 12-19-2014 at 01:00 PM.
  #2  
Old 12-24-2014, 12:39 PM
Axiom
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Polar View Post
Hi,

I followed the instruction from your site : http://help.ecwid.com/customer/portal/articles/1171402

The player that you suggest works fine on PC based browsers, but not on Android and iOS. So I tested another solution. I installed a player on my web server, and when running it from a local page it works fine. The code is following: (can be placed entirely in the body):
HTML Code:
    <!-- start Audio.js -->
    <script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
    <script>
      audiojs.events.ready(function() {
        audiojs.createAll();
      });
    </script>
    <!-- end Audio.js -->
<audio src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3" preload="auto"> </audio>
However, when I enter the code in my ECWID product HTML page, after saving it looks different from the original, and the player won't show when loading the page in your browser.
HTML Code:
<!-- start Audio.js -->
<script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
<script type="text/javascript">// <![CDATA[ 
      audiojs.events.ready(function() {
        audiojs.createAll();
      });
// ]]></script>

<!-- end Audio.js --> <audio preload="auto" src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3"> </audio>
The direct link is: http://care4u.ecwid.com/#!/Selvhypno...egory=11696035

Please your advice.

I did some further testing. First I installed a fresh web page on another domain. From that page I called the remote js script and the remote mp3 from domain A. Worked OK.

Next test: I see that the html from ECWID is rewritten and parsed. I removed the lines :
HTML Code:
<script>
audiojs.events.ready(function() {
audiojs.createAll();
});
</script>
and made a seperate external js file of it. Now the html code looks like this:
HTML Code:
<script src="http://www.care4-u.no/js/audiojs/audiojs/audio.min.js"></script>
<script src="http://www.care4-u.no/js/audiojs/audiojs/external.js"></script>
<audio src="http://www.care4-u.no/butikk/samples/mp3-hypnose-4-lovers-64-sample.mp3" preload="auto"> </audio>
Still not working, but it works fine when running this from domain B. (calling the js and MP3 from domain A).

So there is something on your server that stops the player from showing. The html code (chrome>>inspect element) however is including the scripts and the audio tag.
Hello!

Thank you for your post!
To begin with let me tell you that there is no way to use JavaScript codes on product detail page but Ecwid allows to embed Flash to the product descriptions, so you can add a flash audio player to your product descriptions. Please, perform the following steps:
1. Upload your audio clips to any hosting. If you don't have one, use Dropbox.
2. Add a Flash audio player which plays these clips to the product descriptions.

I’ve found a Top 21 free players for the website, maybe you’ll find the one that suits your site: http://www.instantshift.com/2010/02/...-your-website/.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:47 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.