The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 02-28-2016, 01:26 AM
fgwinn's Avatar
fgwinn is offline
 
Join Date: Jan 2013
Posts: 24
Default

Prices do not display when using Internet Explorer


I have been using the Ecwid shopping cart successfully since March 2013. In 2015 we integrated YotPo reviews with Ecwid. At the beginning of 2016 we added MailChimp integration.

Recently we noticed that item catalog pictures were not displaying with YotPo reviews. We reported this issue to YotPo and it has since been resolved.

This past week a couple of customers have reported that no prices are displayed in the online store when using Internet Explorer. Chrome, Safari, and Firefox work fine. But with Internet Explorer prices only show up just before the point you would enter your credit card number.

I mentioned the recent YotPo fix and MailChimp integration since the "no price display" issue only seemed to occur after these "changes".

I am certain that I am losing sales due to this price display issue.

My Ecwid store is at www.reverselogic.us/shop.html

The screen capture showing the price is from Firefox browser. The one without price is IE.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2016-02-27 at 8.23.41 PM.png
Views:	154
Size:	192.2 KB
ID:	3376   Click image for larger version

Name:	Screen Shot 2016-02-27 at 8.25.07 PM.png
Views:	109
Size:	93.8 KB
ID:	3377  

Last edited by Liza; 02-28-2016 at 07:34 AM.
  #2  
Old 04-05-2016, 09:13 AM
treb's Avatar
treb treb is offline
Junior Member
 
Join Date: Apr 2016
Posts: 1
Default

Hello,
I have the same problem : no price appears, and no price in the shopping cart. It is very boring because most of costumers use Internet Explorer...
  #3  
Old 04-16-2016, 03:52 PM
Cyril D's Avatar
Cyril D Cyril D is offline
Ecwid Team
 
Join Date: Feb 2015
Location: Ecwid HQ
Posts: 530
Default

Hello guys,

We're sorry we missed your messages!

Fredric, I know it's been a while but I've checked your website in Internet Explorer 11 running on Windows 10 and all prices appear just fine on my end (screenshot). Have you managed to solve the problem yourself or am I missing something? If the problem's still there, please let me know the version of your Internet Explorer and Windows. It'll help us to troubleshoot the issue further.

Quote:
Originally Posted by treb View Post
I have the same problem : no price appears, and no price in the shopping cart. It is very boring because most of costumers use Internet Explorer...
I'm sorry about this, Treb. May I have a link to a page that illustrates the issue? Having the version of your Internet Explorer, Windows, and a screenshot indicating the problem would be helpful as well.

Thank you in advance and hope to hear from you soon!
__________________
Cyril D.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.
  #4  
Old 04-16-2016, 04:01 PM
fgwinn's Avatar
fgwinn fgwinn is offline
 
Join Date: Jan 2013
Posts: 24
Default

I got desperate and signed up for an Ecwid Health Check session. It turned out that the default font for the price was not one that was supported by IE.

We added the following code to the CSS Theme and the problem was fixed.


html#ecwid_html body#ecwid_body .ecwid, html#ecwid_html body#ecwid_body .ecwid-minicart, html#ecwid_html body#ecwid_body .ecwid-SearchPanel, html#ecwid_html body#ecwid_body .dateBoxPopup, html#ecwid_html body#ecwid_body .gwt-PopupPanel {
font-family: sans-serif;
}
  #5  
Old 04-16-2016, 08:16 PM
Cyril D's Avatar
Cyril D Cyril D is offline
Ecwid Team
 
Join Date: Feb 2015
Location: Ecwid HQ
Posts: 530
Default

Fredric,

Thank you very much for the update! I'm glad that the issue was sorted. I'm sorry that you had to sign up to the Health Check, though.

As for the default font, here's the default font-family parameter that was overridden by the code added to you custom CSS theme in the Ecwid Control Panel → Settings → Design → Custom CSS Themes:

Code:
font-family: -apple-system,"BlinkMacSystemFont","Open Sans",sans-serif;
It works as follows: if the first three are not found installed, the browser will select the best option, but only from sans-serif fonts. Without the generic family, the font would default to whatever is the default font on the user's system, which would be undesirable. As you can see, the parameter contains the same generic family value as the code in your custom theme and the price would appear in any case. I've just checked it in my test store and it has worked perfectly in Internet Explorer 11.

However, if the default Ecwid's font rules were overridden by your site's CSS, it might be the case.

Hope this was helpful! Please, let me know if you have any further questions.
__________________
Cyril D.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:20 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.