The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 04-01-2010, 04:01 PM
shakarbakery's Avatar
shakarbakery is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Cool

My page loads super slow


I installed this incredible plugin and I absolutely LOVE it! great job to the engineers.
however, I have a problem...it takes a whopping 8-10 seconds for it to load completely on my website. This is bad bad bad for my business. My bounce rate is going to start increasing soon if I don't get this fixed. I set up the website myself using wordpress and godaddy as a server. A company wants to charge me $650 to optimize this widget, and quite frankly, I don't have that kind of money to spend in this economy! I'm sure there's a much easier way to get this fixed. Please help, I really love this plugin and I want to keep using it! the website is www.shakarbakery.com
thank you so much!
  #2  
Old 04-01-2010, 04:56 PM
shakarbakery's Avatar
shakarbakery shakarbakery is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Exclamation

I saw an older thread with a similar problem. I installed firebug but have no idea what I'm supposed to look for
  #3  
Old 04-02-2010, 11:53 AM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by shakarbakery View Post
I installed this incredible plugin and I absolutely LOVE it! great job to the engineers.
however, I have a problem...it takes a whopping 8-10 seconds for it to load completely on my website. This is bad bad bad for my business. My bounce rate is going to start increasing soon if I don't get this fixed. I set up the website myself using wordpress and godaddy as a server. A company wants to charge me $650 to optimize this widget, and quite frankly, I don't have that kind of money to spend in this economy! I'm sure there's a much easier way to get this fixed. Please help, I really love this plugin and I want to keep using it! the website is www.shakarbakery.com
thank you so much!
Hi,

You don't need to pay anybody $650 to make your Ecwid store to be fast. Well, it was initially designed to be a fast shopping cart: http://www.ecwid.com/blog/ecommerce/speed-matters.html

I've tested your store - it loads fast.

So first we need to find out where the delays have place and why you face them.
Is it your WordPress blog that loads slowly or your store?

Please let me know the following:

1. How our demo store works for you?
2. How this test store works for you?
3. Can you test your store using a completely different Internet connection?
4. What browser do you use?
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #4  
Old 04-02-2010, 03:43 PM
shakarbakery's Avatar
shakarbakery shakarbakery is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Default

Hi, thank you for the reply!

1.I tried the demo store on your site, that also takes about 5-8 seconds to load (that means I see the loading bar for that long before the products pop up).
2. I have accessed my site from different internet connections, and asked my friends to test it on theirs too. everyone says the store takes too long to load before the products show up.
3. when i load my site www.shakarbakery.com, wordpress starts to load. when it lags, i see at the bottom that it says www.app.ecwid.com, then it loads my google analytics, and then back to www.app.ecwid.com. could it be that i have too many products loading on one page? i don't want them separated into categories. how can i change how many load on a single page?
4. i use mozilla firefox. it takes approximately 8 seconds for the loading bar to go away. i tested it on internet explorer, and it was even worse, almost 20 seconds!

I've also tried to copy paste the html code onto my wordpress, and that was a lot slower.
once the product page loads, the cart itself is great! everything runs smoothly and quickly. the only problem thus far is just getting the products to load.
  #5  
Old 04-02-2010, 07:32 PM
shakarbakery's Avatar
shakarbakery shakarbakery is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thumbs up

hi again!

I tested the website loading time again from home vs work, and it loads faster on my network at home. It takes about 4 seconds to load completely there.
It obviously varies with whatever network I'm using, so there's nothing we can do about that!
  #6  
Old 04-04-2010, 04:35 PM
Benny Kusman's Avatar
Benny Kusman Benny Kusman is offline
Junior Member
 
Join Date: Mar 2010
Posts: 13
Default

it loads slow now..

i have raised this issue earlier in another thread.. seems that the store is trying to load but it doesnt end...
Attached Thumbnails
Click image for larger version

Name:	Picture 1.gif
Views:	171
Size:	89.1 KB
ID:	234  
  #7  
Old 04-05-2010, 10:08 AM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by shakarbakery View Post
hi again!

I tested the website loading time again from home vs work, and it loads faster on my network at home. It takes about 4 seconds to load completely there.
It obviously varies with whatever network I'm using, so there's nothing we can do about that!
Thank you for all the information.

Please also perform the following test:

1. Launch Firefox and open the Firebug console.
2. Go to the Network tab.
3. Refresh the Store page. What do you see in Firebug?
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #8  
Old 04-23-2010, 07:12 PM
American Powertrain's Avatar
American Powertrain American Powertrain is offline
 
Join Date: Dec 2009
Posts: 80
Default

Quote:
Originally Posted by qetzal View Post
Thank you for all the information.

Please also perform the following test:

1. Launch Firefox and open the Firebug console.
2. Go to the Network tab.
3. Refresh the Store page. What do you see in Firebug?
Eugene,
Mine says 1.36s (onload: 7.53s) But my friend sent me a video of his loading and it takes 9 minutes on dialup. I have very little excess coding on my cart page, but could you tell me what might be slowing my site down. Sometimes I even use it and it's much slower than 7 seconds (which is too much to begin with).

Tina
  #9  
Old 04-24-2010, 01:03 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by American Powertrain View Post
Eugene,
Mine says 1.36s (onload: 7.53s) But my friend sent me a video of his loading and it takes 9 minutes on dialup. I have very little excess coding on my cart page, but could you tell me what might be slowing my site down. Sometimes I even use it and it's much slower than 7 seconds (which is too much to begin with).

Tina
1. The numbers in the "Onload" row of a "Net" Firebug tab show the total time of downloading of ALL elements of your site. I.e. your site's images, Javascript, HTML code, etc.

2. I agree 9 minutes to load a site is too long, even on a dialup.
Possible reasons:
- site has too many elements, for ex. big images
- some issues with the Internet connection

Since you've already contacted me regarding this issue by e-mail, I will reply you by e-mail too with the result of my investigations.
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #10  
Old 04-08-2012, 11:09 PM
BSZ's Avatar
BSZ BSZ is offline
Junior Member
 
Join Date: Oct 2011
Posts: 6
Default

Hi, I'm trying to get my store to load faster than it currently does... Could you please be so kind to have a look at http://www.thaibuddhistamulets.net and share your view on what could be improved in order to make ecwid load faster on my wordpress site (version 3.3.1 and using atahualpa theme 3.7.3).

Your advice would be greatly appreciated; thanks in advance!

(already did the 'simple store test' for my ecwid store and was pleased about the loading time, also checked the advice given in 'speed matters'. Have tried viewing my site in several different browsers (IE, Firefox and Google Chrome) and tried this on different computers and internet connections, but the results all seem to be more or less the same (approximately 8-10 seconds loading time)
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
optimize, slow load, troubleshoot

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:07 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.