The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 07-12-2013, 11:28 AM
JulieG's Avatar
JulieG is offline
Junior Member
 
Join Date: Aug 2012
Posts: 13
Default

Responsive / adaptive design issues (Ecwid v 14)


Dear Ecwid team,

Many thanks for launching the responsive design - it's been quite a journey!

Currently testing it on our responsive dev site and have noticed the following on Android:

1. The 'sign in' dialog is half off the right side of the screen in portrait. In landscape, the dialog jumps about and then settles horizontally centred although it's difficult to type in the form due to the height of the keyboard.

2. 'View detailed images' doesn't always have a close button (perhaps due to the width of the image being displayed?). Also, navigation buttons would be useful. especially in portrait where the thumbnails aren't shown.

3. At checkout, in portrait the ' X Remove' button we've chosen (as per Ecwid tip) covers fully or partially, depending on the length of the item title, the Subtotal figure.

Hope this feedback helps and look forward to a solid mobile user experience :-)

Thanks again!
  #2  
Old 07-12-2013, 08:30 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by JulieG View Post
Dear Ecwid team,

Many thanks for launching the responsive design - it's been quite a journey!

Currently testing it on our responsive dev site and have noticed the following on Android:

1. The 'sign in' dialog is half off the right side of the screen in portrait. In landscape, the dialog jumps about and then settles horizontally centred although it's difficult to type in the form due to the height of the keyboard.

2. 'View detailed images' doesn't always have a close button (perhaps due to the width of the image being displayed?). Also, navigation buttons would be useful. especially in portrait where the thumbnails aren't shown.

3. At checkout, in portrait the ' X Remove' button we've chosen (as per Ecwid tip) covers fully or partially, depending on the length of the item title, the Subtotal figure.

Hope this feedback helps and look forward to a solid mobile user experience :-)

Thanks again!
Hi,

Thank you for the report! I've been able to reproduce some of these issues on my test Ecwid on simple store and on your site http://www.ceragem-uk.com/store For now I tested it on Android Asus Transformer tablet. We're investigating them and will keep you posted.
And I need more information on the following:
- Are you reporting on your site http://www.ceragem-uk.com/store ? Or should we check another one?
- What Android device are you using?
- I always see 'sign in' link displayed fine, it's not off to the side of the screen in portrait. Could you take a screenshot? Perhaps we need to check it on the same devices as you have
- What do you mean by thumbnails aren't shown? I can see thumbnails on all products lists.

Thank you again. Look forward to hearing from you.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #3  
Old 07-13-2013, 05:53 PM
JulieG's Avatar
JulieG JulieG is offline
Junior Member
 
Join Date: Aug 2012
Posts: 13
Default

Hi,

Thanks for your reply. Responses to your questions:

- Are you reporting on your site http://www.ceragem-uk.com/store ? Or should we check another one?
-> Our new responsive store is at this dev URL:
http://www.ceragem-uk.com/love4/index.php?id=2
- What Android device are you using?
-> Testing on a Motorola Defy MB525 with Dolphin and stock browser
- I always see 'sign in' link displayed fine, it's not off to the side of the screen in portrait. Could you take a screenshot? Perhaps we need to check it on the same devices as you have
-> Sorry this wasn't clear. The 'sign in' link displays fine. I was referring to the dialog that appears following clicking/tapping the 'sign in' link. Noticed that the "The 'sign in' dialog is half off the right side of the screen in portrait." seems to be okay now - the dialog now appears on a white background (as when viewed in landscape too) and horizontally centered (see screenshots - link below)
- What do you mean by thumbnails aren't shown? I can see thumbnails on all products lists.
-> I was referring to the thumbnails that are not shown when the 'View detailed images' dialog is viewed in portrait - the dialog that appears after clicking/tapping the 'View detailed images' link or any of the thumbnails on a product page.

Noticing slow performance. Most first time clicks (after reloading the store page) need up to 30 seconds to respond and the loading bar doesn't always show so, to the user, it looks unresponsive ;-) Experiencing these long delays when clicking 'sign-in', products in the PB, nav arrows in the 'You may like' section, Continue shopping button, Checkout button, next/prev product nav buttons... Wondering if this is due to a timeout/conflict with another script(s)?

Also, the Checkout button doesn't animate and the Mini-cart doesn't respond to clicks/taps.

There are a few screenshots at:

https://plus.google.com/photos/11528...CIOa0q7OyaSBSg

Hope this helps.

Best wishes and much gratitude to you and all the team!
  #4  
Old 07-15-2013, 09:56 AM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by JulieG View Post
Hi,

Thanks for your reply. Responses to your questions:

- Are you reporting on your site http://www.ceragem-uk.com/store ? Or should we check another one?
-> Our new responsive store is at this dev URL:
http://www.ceragem-uk.com/love4/index.php?id=2
- What Android device are you using?
-> Testing on a Motorola Defy MB525 with Dolphin and stock browser
- I always see 'sign in' link displayed fine, it's not off to the side of the screen in portrait. Could you take a screenshot? Perhaps we need to check it on the same devices as you have
-> Sorry this wasn't clear. The 'sign in' link displays fine. I was referring to the dialog that appears following clicking/tapping the 'sign in' link. Noticed that the "The 'sign in' dialog is half off the right side of the screen in portrait." seems to be okay now - the dialog now appears on a white background (as when viewed in landscape too) and horizontally centered (see screenshots - link below)
- What do you mean by thumbnails aren't shown? I can see thumbnails on all products lists.
-> I was referring to the thumbnails that are not shown when the 'View detailed images' dialog is viewed in portrait - the dialog that appears after clicking/tapping the 'View detailed images' link or any of the thumbnails on a product page.

Noticing slow performance. Most first time clicks (after reloading the store page) need up to 30 seconds to respond and the loading bar doesn't always show so, to the user, it looks unresponsive ;-) Experiencing these long delays when clicking 'sign-in', products in the PB, nav arrows in the 'You may like' section, Continue shopping button, Checkout button, next/prev product nav buttons... Wondering if this is due to a timeout/conflict with another script(s)?

Also, the Checkout button doesn't animate and the Mini-cart doesn't respond to clicks/taps.

There are a few screenshots at:

https://plus.google.com/photos/11528...CIOa0q7OyaSBSg

Hope this helps.

Best wishes and much gratitude to you and all the team!
Hi,

Thank you very much for the details. We continue working on the issues, I'll keep you posted.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #5  
Old 07-17-2013, 02:22 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by JulieG View Post
- What do you mean by thumbnails aren't shown? I can see thumbnails on all products lists.
-> I was referring to the thumbnails that are not shown when the 'View detailed images' dialog is viewed in portrait - the dialog that appears after clicking/tapping the 'View detailed images' link or any of the thumbnails on a product page.
Hi,

This problem has been fixed. Please, check how 'View detailed images' is now opened on your device, and let me know.

We continue working on the other issues.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #6  
Old 07-17-2013, 07:04 PM
JulieG's Avatar
JulieG JulieG is offline
Junior Member
 
Join Date: Aug 2012
Posts: 13
Default

Hi Lana, thanks for your update.

Unfortunately, the experience on the MB525 phone appears unchanged. See the 8 screenshots at the top of this page:

https://plus.google.com/photos/11528...CIOa0q7OyaSBSg

Best wishes!
  #7  
Old 07-18-2013, 01:05 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by JulieG View Post
Hi Lana, thanks for your update.

Unfortunately, the experience on the MB525 phone appears unchanged. See the 8 screenshots at the top of this page:

https://plus.google.com/photos/11528...CIOa0q7OyaSBSg

Best wishes!
Hi,

Yes, I can reproduce the problem. Sorry for the troubles. We continue working on this case. I'll keep you posted.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #8  
Old 08-09-2013, 05:27 PM
JulieG's Avatar
JulieG JulieG is offline
Junior Member
 
Join Date: Aug 2012
Posts: 13
Default

Wondering if there is any progress with this? Looking forward to hearing from you. Best wishes!
  #9  
Old 08-14-2013, 01:32 PM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by JulieG View Post
Wondering if there is any progress with this? Looking forward to hearing from you. Best wishes!
Hi,

Sorry for keeping you waiting. We have detected several problems on Android devices, include those you reported, and are working on it. They're quite difficult and we doesn't want to issue quick fixes. Some needs redesigning, for ex., the viewing of detailed images demands change of the popup.
I will let you know when we find solutions and proceed to testing.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
  #10  
Old 08-14-2013, 05:28 PM
JulieG's Avatar
JulieG JulieG is offline
Junior Member
 
Join Date: Aug 2012
Posts: 13
Default

Thank you team for all your efforts. I wish you a very graceful process.

BTW I recently discovered this popup:

http://dimsemenov.com/plugins/magnific-popup/

I've noticed it preforms very well on my Android phone unlike fancybox or Colourbox that I'd used for years.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
responsive design

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:39 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.