The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #11  
Old 08-21-2011, 04:00 PM
swift's Avatar
swift is offline
Senior Member
 
Join Date: Jan 2010
Posts: 167
Default


Quote:
Originally Posted by Kaelin Cordis View Post
Nevermind, I added titles just fine, and am now trying to figure out how to get the return info in https encrypted format. Seems the API is only returning http syntax for some reason. Have I mentioned how much I like your plugin?
Great idea to add titles. I will add it in next version as an option.
As for HTTPS connection, I see the problem too and of course it will be fixed. Thanks a lot for feedback!

Thank you for your kind words. I do appreciate it!
  #12  
Old 08-21-2011, 05:34 PM
swift's Avatar
swift swift is offline
Senior Member
 
Join Date: Jan 2010
Posts: 167
Default

Module has been just approved by WordPress team and it can be downloaded from here:
http://wordpress.org/extend/plugins/ecwid-useful-tools/

BTW, I have added an update for HTTPS bug.
  #13  
Old 08-22-2011, 12:44 AM
Kaelin Cordis's Avatar
Kaelin Cordis Kaelin Cordis is offline
 
Join Date: Aug 2010
Location: In between Morning Coffee and the Land of Nod
Posts: 104
Thumbs up Excellent Plugin

Quote:
Originally Posted by swift View Post
Great idea to add titles. I will add it in next version as an option.
As for HTTPS connection, I see the problem too and of course it will be fixed. Thanks a lot for feedback!

Thank you for your kind words. I do appreciate it!
No problem.

Noticed today that the alt tags for the images have a period in front of them, which comes from this line:

title=".' . $product['name'] . '"

I've removed it on my copy, but I did want to point it out. I really appreciate you fixing the https! Thanks! I've added it to my client's sites as well, and it's just wonderful.
  #14  
Old 08-23-2011, 08:25 PM
swift's Avatar
swift swift is offline
Senior Member
 
Join Date: Jan 2010
Posts: 167
Default

Quote:
Originally Posted by Kaelin Cordis View Post
Noticed today that the alt tags for the images have a period in front of them, which comes from this line:

title=".' . $product['name'] . '"
It has been fixed also. Thanks a lot for pointing out these small bugs.

I have updated module to 0.2 version.
Now you can define whether to show product's name and/or price under product's thumbnail.

Any feedback is always welcome.
  #15  
Old 08-23-2011, 09:08 PM
daniel patin's Avatar
daniel patin daniel patin is offline
 
Join Date: Jul 2010
Posts: 33
Default

thats work fine, but only the currency symbol is not shown in the widget, before or after the price.
  #16  
Old 08-23-2011, 09:16 PM
swift's Avatar
swift swift is offline
Senior Member
 
Join Date: Jan 2010
Posts: 167
Default

Quote:
Originally Posted by daniel patin View Post
thats work fine, but only the currency symbol is not shown in the widget, before or after the price.
Basically, price is shown as currencyPrefix price-value currencySuffix.

So, in your particular case you should define currecySuffix in Ecwid Control Panel as euro sign and it will look as you need.
  #17  
Old 08-23-2011, 09:28 PM
daniel patin's Avatar
daniel patin daniel patin is offline
 
Join Date: Jul 2010
Posts: 33
Default

I'm sorry but I had already chosen this option
  #18  
Old 08-24-2011, 03:12 PM
swift's Avatar
swift swift is offline
Senior Member
 
Join Date: Jan 2010
Posts: 167
Default

Quote:
Originally Posted by daniel patin View Post
I'm sorry but I had already chosen this option
You are using free Ecwid account, so the module cannot get profile's settings via API.
That's why currency suffix and prefix cannot be displayed on-fly.

I will add an option to handle this situation in the future.

Currently, you can edit the next piece of code:
$to_return .= $profile['currencyPrefix'] . $product['price'] . $profile['currencySuffix'];

in the ecwid-useful-tools.php script in order to hard-code the currency.

In your particular case, it should be replaced with:
$to_return .= $product['price'] . '€';

Surely, upgrading to paid account will fix the problem as well.
  #19  
Old 08-24-2011, 03:23 PM
daniel patin's Avatar
daniel patin daniel patin is offline
 
Join Date: Jul 2010
Posts: 33
Default

thanks for this solution. today, my shop is too small for paid account :-(
  #20  
Old 08-24-2011, 03:33 PM
daniel patin's Avatar
daniel patin daniel patin is offline
 
Join Date: Jul 2010
Posts: 33
Default

small change, I added a space before the currency symbol, and it works very well:

$to_return .= $product['price'] . ' €';
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
ecwid, plugin, products, random, random products, random products plugin, stylesheet, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:13 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.