The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 04-21-2015, 10:00 PM
Larry Lefkowitz's Avatar
Larry Lefkowitz is offline
Junior Member
 
Join Date: Apr 2015
Posts: 11
Default

Changed embedded "Add to Bag Button" not displaying


I have created a new version of the embedded "Add to Bag" button, but it is not displaying.

Here is the modified CSS Code:

html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-up, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-up-hovering, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6-up, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6-up-hovering {
background: url("http://page-graphics.com/musetest/assets/add-to-bag.png") no-repeat scroll center top transparent;
}

html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6 {
height: 29px;
width: 147px;
}

Any ideas as to why this isn't working?

Thanks.
  #2  
Old 04-21-2015, 11:23 PM
Christopher Gaines's Avatar
Christopher Gaines Christopher Gaines is offline
 
Join Date: Feb 2015
Posts: 2
Default

Hello,

I believe what you are missing is the !important tag, which overrides any current CSS you have on your store. You can also condense your css quite a bit. This code should work for you:

Code:
div.ecwid-AddToBagButton-up, div.ecwid-AddToBagButton-up-hovering, div.ecwid-AddToBagButton-ie6-up, div.ecwid-AddToBagButton-ie6-up-hovering {
  background: url("http://page-graphics.com/musetest/assets/add-to-bag.png") no-repeat scroll center top transparent !important;
}
div.ecwid-AddToBagButton, div.ecwid-AddToBagButton-ie6 {
  height: 29px;
  width: 147px;
}
Let me know if you need further help

-Chris

Last edited by Liza; 04-29-2015 at 02:50 PM.
  #3  
Old 04-22-2015, 04:04 AM
Rick G's Avatar
Rick G Rick G is offline
Ecwid Team
 
Join Date: Jun 2014
Posts: 1,270
Default

Quote:
Originally Posted by Larry Lefkowitz View Post
I have created a new version of the embedded "Add to Bag" button, but it is not displaying.

Here is the modified CSS Code:

html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-up, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-up-hovering, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6-up, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6-up-hovering {
background: url("http://page-graphics.com/musetest/assets/add-to-bag.png") no-repeat scroll center top transparent;
}

html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton, html#ecwid_html body#ecwid_body div.ecwid-AddToBagButton-ie6 {
height: 29px;
width: 147px;
}

Any ideas as to why this isn't working?

Thanks.
Hi,

Thank you for contacting us.

I checked your current CSS theme and I see that the new image for your add to bag button isn't applied because there are unsupported characters located right before the actual CSS property like 'background' and others.

Please replace your code with the one from this page in your Custom CSS themes in Ecwid control panel > System settings > Design and save the changes.

http://pastebin.com/raw.php?i=C6KexnBz

As a result, your button will be applied perfectly: http://take.ms/mRv4C
Thank you.
__________________
Ecwid API and App Market Team
Ecwid Developer Website
The Following User Says Thank You to Rick G For This Useful Post:
Larry Lefkowitz (04-22-2015)
  #4  
Old 04-22-2015, 04:55 PM
Larry Lefkowitz's Avatar
Larry Lefkowitz Larry Lefkowitz is offline
Junior Member
 
Join Date: Apr 2015
Posts: 11
Default

Thank Vitaly,

That worked! I was also wondering about the "html#" characters, but I copied the CSS directly from Firebug, so I thought it was okay.

Thanks again, and everyone for their suggestions.
  #5  
Old 04-22-2015, 05:57 PM
Rick G's Avatar
Rick G Rick G is offline
Ecwid Team
 
Join Date: Jun 2014
Posts: 1,270
Default

Quote:
Originally Posted by Larry Lefkowitz View Post
Thank Vitaly,

That worked! I was also wondering about the "html#" characters, but I copied the CSS directly from Firebug, so I thought it was okay.

Thanks again, and everyone for their suggestions.
Hi,

Thank you for the update! I see that your add to bag button is displayed correctly now and I'm glad that my suggestion worked for you. Should you have any questions in the future - please don't hesitate to ask.
__________________
Ecwid API and App Market Team
Ecwid Developer Website
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Tags
css

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:38 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.