The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 02-15-2012, 01:09 AM
mr.ericturner's Avatar
mr.ericturner is offline
 
Join Date: Feb 2012
Posts: 9
Default

Changing email notification template


Hi all,

I've been trying to customize the "New Order" email that goes out to admin, but no matter what changes I make, it still comes out looking basically the same when I test it by doing a test order. The changes I make aren't being reflected in the email that comes to admin; they don't seem to take effect. I'm being careful not to strip out the tags, so that doesn't seem to be the issue.

Examples:

* I want to change the headers to be more descriptive, such as changing "==== Items ====" to "===== Customer Selected these Items ====". But when I make the change and save it, then do a test email, the change has not taken effect.


* I want to change the email Subject to something else, but no matter what I sub into the Subject field, it still shows only the Store Name and Order# when I do a test email.


Is there something hard-coded that's forcing such items to revert back to their default state? If so, what can I do to have more customization options for the system email messages?


Thanks very much,
Eric
  #2  
Old 02-15-2012, 08:43 AM
Kess's Avatar
Kess Kess is offline
Senior Member
 
Join Date: Feb 2012
Posts: 2,071
Default

I have checked the admin notifications editing mechanism and made sure it works correctly. So I suppose there are two possible origins of the issue you're facing:
1. You may be editing the wrong notification. The one you need is "Order is completed". Please find it in your Ecwid control panel -> System settings -> 'Mail' tab.

2. You may be missing the last step of the saving changes procedure. So after you find "Order is completed" notification as described above, click on 'Edit message' link next to it and modify the Subject and '==== Items ====' text, you click on the 'Save' button at the bottom of the page. And after the you return back to Mail settings page, where you should click the large 'Save (Ctrl+S)' button to the right as well. If you miss this last step, the changes won't be applied. So please don't forget to click that button as well.
  #3  
Old 02-17-2012, 03:04 PM
HIT's Avatar
HIT HIT is offline
 
Join Date: Jan 2012
Posts: 41
Default Changing Customer Notification (edited wrong one?)

I just performed a test sale and I (as customer) received this email

Quote:
Thank you for your purchase with Hospitalinventorytrader.com

Order Number: 12
Order Date: Feb 17, 2012 09:58 AM EST

==== Items ====

ST JUDE MEDICAL - 8FR ANGIOSEAL VIP, CAT# 610131, Exp Date 2012/08
SKU 00000

Quantity: 1
Price (each): $500.00


==== Order Totals ====

Items: $500.00
Shipping: $0.00
Tax: $0.00
TOTAL: $500.00

-- Payment method --

H.I.T. Contact



-- Billing address --

asd
sd
asd
Minneapolis, MN, 55405
United States
Phone 5

Thank you once again for your order.

---
Hospital Inventory Trader


, ,
United States
Phone

Email: sales@hospitalinventorytrader.com
How can I edit this e-mail? I have already edits the Customer Notification "Order is Complete" with some new copy, but this doesn't seem to be that email. This also isn't Password Reminds, Successful Registration, Order is Rejected, EGoods download or Order Shipped. So I am not sure what to edit to change this copy. Please let me know.
  #4  
Old 02-18-2012, 01:05 AM
mr.ericturner's Avatar
mr.ericturner mr.ericturner is offline
 
Join Date: Feb 2012
Posts: 9
Default

Thank you very much, Kess, I'm thinking this may be the point where I'm supposed to say "Silly me!" I probably have been attempting to edit the wrong message, as you suggested. I was going mostly on the title; "New Order" sounded more like it would be the correct one than "Order is Completed", but I'm sure this is probably the 'issue', and I had not tried editing other messages before coming to the forums, but I should've. I'll get back to you.
  #5  
Old 02-18-2012, 05:48 AM
mr.ericturner's Avatar
mr.ericturner mr.ericturner is offline
 
Join Date: Feb 2012
Posts: 9
Default

A quick follow-up question, Kess. I apologize if I wasn't clear with my original question, but the "Order is Completed" notification you mentioned actually goes to the customer, correct? I was attempting to edit the "New Order" message because that one seems to go to the admin, which is who I am concerned with. I want to edit the message that is going to the admin immediately after a customer places an order..the itemized message with all the order information. Is that not "New Order"? Sorry that I'm so easily confused sometimes, and thank you for helping.

Eric
  #6  
Old 02-20-2012, 06:41 AM
Kess's Avatar
Kess Kess is offline
Senior Member
 
Join Date: Feb 2012
Posts: 2,071
Default

Yes, you are right. If you refer to the message sent to the store admin after an order is placed, you need to modify the "New Order" notification in your Ecwid control panel -> System settings -> 'Mail' tab -> 'Admin notificati​ons' tab.

Please accept my apologies for missing it from the very start.
  #7  
Old 02-20-2012, 06:47 AM
mr.ericturner's Avatar
mr.ericturner mr.ericturner is offline
 
Join Date: Feb 2012
Posts: 9
Default

Apology accepted but not needed.

Well then I guess I'm back where I started from. I've tried editing that one a number of times, and the changes don't seem to take. Any other ideas?

Thanks for your time! I'll keep digging on my end as well.

Eric
  #8  
Old 02-20-2012, 12:23 PM
Kess's Avatar
Kess Kess is offline
Senior Member
 
Join Date: Feb 2012
Posts: 2,071
Default

Ok, to avoid any possible misunderstanding please confirm that you have made all these steps while modifying the notification:

1. Click on 'Edit message' link next to “New Order” notification
2. Modified the ‘Subject’ and '==== Items ====' text,
3. Clicked the 'Save' button at the bottom of the page.
4. Returned back to “Mail settings” page and clicked the ‘'Save (Ctrl+S)" button and the text on the button has turned from white to grey.

If your changes do not apply even after these steps, please report this issue to our bugtracker: http://ecwid.com/bt
  #9  
Old 02-20-2012, 02:14 PM
Kess's Avatar
Kess Kess is offline
Senior Member
 
Join Date: Feb 2012
Posts: 2,071
Default

Actually this notification is "Order is completed". Please find it in your Ecwid control panel -> System settings -> 'Mail' tab -> ‘Customer notificati​ons’.

The reason why it sens the default text instead of your custom one may be the fact that you’re missing the last step of the saving changes procedure. So after you find "Order is completed" notification as described above, click on 'Edit message' link next to it and modify the text there, you click on the 'Save' button at the bottom of the page. And after the you return back to Mail settings page, where you should click the large 'Save (Ctrl+S)' button to the right as well. If you miss this last step, the changes won't be applied. So please don't forget to click that button as well.
  #10  
Old 02-20-2012, 03:17 PM
HIT's Avatar
HIT HIT is offline
 
Join Date: Jan 2012
Posts: 41
Default

I don't believe I missed that step, but just in case I saved it again, using both the save buttons you specified. I tried a test order and I once again got the default.
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:12 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.