The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
 
 
Thread Tools Display Modes
  #1  
Old 08-26-2013, 10:04 AM
Olive's Avatar
Olive is offline
 
Join Date: Feb 2013
Posts: 67
Default

Outdated product image displayed when a FB user 'likes' a product


Hi,

I recently got my Facebook 'like' buttons working for products displayed in my ecwid store.

I had a friend like one of my products from my store so that I could see how it displayed in my Facebook newsfeed.

I was annoyed to see that Facebook displayed the item picture in a square, but because my product images were rectangular shaped the sides were cut off.

To rectify this I went ahead and replaced all my item images (which were rectangular) with square images. This would have ensured that when a customer likes a product from my store that it is displayed much nicer in the newsfeed of their friends (ie, the complete square image would be displayed, rather than a cropped rectangular image).

This brings me to my actual issue. I have updated all product images, but when I had a friend like a product it still populated the old image in the Facebook newsfeed. Put another way, even though the item image has updated in my Ecwid store, this new image is not used when someone 'likes' the product (the old image is used instead).

Screenshot provided below. How do I rectify this?

Thanks very much for your help!

http://imageshack.us/a/img4/4505/502a.png

Last edited by Lana; 08-28-2013 at 09:20 AM.
  #2  
Old 08-29-2013, 10:44 AM
Lanna's Avatar
Lanna Lanna is offline
Ecwid Team
 
Join Date: Jan 2011
Posts: 2,675
Default

Quote:
Originally Posted by NZAccess View Post
Hi,

I recently got my Facebook 'like' buttons working for products displayed in my ecwid store.

I had a friend like one of my products from my store so that I could see how it displayed in my Facebook newsfeed.

I was annoyed to see that Facebook displayed the item picture in a square, but because my product images were rectangular shaped the sides were cut off.

To rectify this I went ahead and replaced all my item images (which were rectangular) with square images. This would have ensured that when a customer likes a product from my store that it is displayed much nicer in the newsfeed of their friends (ie, the complete square image would be displayed, rather than a cropped rectangular image).

This brings me to my actual issue. I have updated all product images, but when I had a friend like a product it still populated the old image in the Facebook newsfeed. Put another way, even though the item image has updated in my Ecwid store, this new image is not used when someone 'likes' the product (the old image is used instead).

Screenshot provided below. How do I rectify this?

Thanks very much for your help!

http://imageshack.us/a/img4/4505/502a.png
Hi,

When you like/share something, Ecwid generates a special shared link containing information on the shared element and passes it to Facebook. Facebook then processes the link and displays the content. For some reasons Facebook cut your first image.
Also Facebook uses a caching mechanism. So the content may be cached on Facebook side. After you changed the product image, further attempts to share it shown the older image - Facebook took it from the cache.

It can be fixed by debugging the shared link with this tool:
https://developers.facebook.com/tools/debug
Shared link can be copied from the link on the shared item on Facebook, screenshot: https://monosnap.com/image/U8IpVJTcQ...bMu2IdHB92.png

When I debugged the shared link for product "Davidoff - Cool Water (for men)", it dropped the cache. So now if you like this product you will see the normal picture. Please, check.

Additionally the debug tool returned this error:
Provided og:image is not big enough. Please use an image that's at least 200x200 px. Image 'http://images-cdn.ecwid.com/images/1848050/94590982.jpg' will be used instead.
As we see Facebook doesn't accept the current product image and intended to use the previous picture. However despite of that the new image is displayed. It seems to be a Facebook glitch, though it doesn't look like affecting your products. We'll try to find more about it.
__________________
Lana W.
Ecwid Customer Care Team

More tips and hints on Ecwid use in our Help Center

⬇ Please click Thanks if my reply helped you.

Thank Ecwid team on Twitter
The Following User Says Thank You to Lanna For This Useful Post:
Olive (08-29-2013)
  #3  
Old 08-29-2013, 08:19 PM
Olive's Avatar
Olive Olive is offline
 
Join Date: Feb 2013
Posts: 67
Default

Thanks Lana, very helpful!
  #4  
Old 08-30-2013, 06:52 AM
michal mick's Avatar
michal mick michal mick is offline
Junior Member
 
Join Date: Aug 2013
Posts: 2
Default

o that's a great idea Anyone have good how to on the comments plugin? Specifically how to moderate comments and such?thanks for your help
 
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:12 AM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.