The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 07-17-2010, 09:28 AM
The Cycle Shed's Avatar
The Cycle Shed is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Default

The "Like" button


I dont understand wat u guys are talking about but i can't get the like button to work right. here is what i am doing to test it.

1.browse to product on my site and get link
http://www.thecycleshed.com/products...roduct=1063225

2.go to facebook social plugins
http://developers.facebook.com/docs/...e/plugins/like

3. paste link into facebook area and get the code from facebook for the like button.

4.open ecwid control panel and go to the product. edit the html of the product description. paste code into product description.

result. i test by going to product page and it does appear. I click the like button and it does post to facebook. on facebook I click the link that it says i like and it goes to my website homepage www.thecycleshed.com. i expected it to go to the product page that i made the link for.

her is the code that facebook generated for me

<iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.thecycleshed.com%2F productstest.htm%23ecwid%3Acategory%3D331207%26mod e%3Dproduct%26product%3D1063225&amp;layout=standar d&amp;show_faces=false&amp;width=450&amp;action=re commend&amp;font=tahoma&amp;colorscheme=light&amp; height=35" style="border: none; overflow: hidden; width: 450px; height: 35px;" allowtransparency="true" scrolling="no" frameborder="0"></iframe>
  #2  
Old 07-18-2010, 12:32 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Could you please open your store and post a link to a product with this button installed?
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #3  
Old 07-27-2010, 11:32 PM
The Cycle Shed's Avatar
The Cycle Shed The Cycle Shed is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Default

I opened it up for u to go to. here is a pic of what gets posted to FB also

the link to the product page with the like button is in the first post

http://i23.photobucket.com/albums/b3...stuff/bug3.jpg

  #4  
Old 07-28-2010, 04:41 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by The Cycle Shed View Post
I opened it up for u to go to. here is a pic of what gets posted to FB also

the link to the product page with the like button is in the first post

http://i23.photobucket.com/albums/b3...stuff/bug3.jpg
Thanks.

When you click a "Like" button, Facebook tries to get some information about a page: title, descriptions, thumbnail. In this particular case Facebook doesn't get it right and shows some JS code instead of actual description.

In order to fix the problem, please try to specify the special site meta tags, describing your site:
- http://developers.facebook.com/docs/...e/plugins/like
- http://wiki.developers.facebook.com/...ying_Meta_Tags
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #5  
Old 07-28-2010, 07:31 PM
The Cycle Shed's Avatar
The Cycle Shed The Cycle Shed is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Default

I now have this

Code:
<iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.thecycleshed.com%2Fproductstest.htm%23ecwid%3Acategory%3D331207%26mode%3Dproduct%26product%3D1063225&amp;layout=standard&amp;show_faces=false&amp;width=450&amp;action=recommend&amp;font=tahoma&amp;colorscheme=light&amp;height=35" style="border: none; overflow: hidden; width: 450px; height: 35px;" allowtransparency="true" scrolling="no" frameborder="0"></iframe>

<meta name="title" content="KTM FMF Factory Pipe 250/300" /> 
<meta name="description" content="The FMF-SXS pipe for 250/300 KTM" /> 
<link rel="image_src" href="http://app.ecwid.com/image/2434053?ownerid=143917" / >

I put that in the product description and it doesn't seem to use the meta tags at all. I get the same result
  #6  
Old 07-28-2010, 07:43 PM
Clint McJenkin's Avatar
Clint McJenkin Clint McJenkin is offline
 
Join Date: Apr 2010
Location: Tuscaloosa, AL
Posts: 7
Default Example.com

When I do this, it links to example.com? I am inputing the item's specific url - http://www.fighterwear.net/ecwid/#ec...roduct=1048700 - and I get this example.com link as the result. Any idea why?

I can go in and edit the code, but I want to know why it does this. Or if I am doing something wrong.
__________________
Clint McJenkin
Co-Founder / Fighterwear.net
205-792-0938 • clint@fighterwear.net
www.fighterwear.net
Facebook • Twitter: @Fighterwear_net
  #7  
Old 07-29-2010, 03:21 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
I put that in the product description and it doesn't seem to use the meta tags at all. I get the same result
These meta tags should be added to the page header, between the <head> and </head> tags.

Quote:
When I do this, it links to example.com? I am inputing the item's specific url - http://www.fighterwear.net/ecwid/#ec...roduct=1048700 - and I get this example.com link as the result. Any idea why?
Did you also try to add the Like button?
I've checked the link and haven't found any.
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base
  #8  
Old 07-29-2010, 06:58 PM
The Cycle Shed's Avatar
The Cycle Shed The Cycle Shed is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Default

If I put it in the header that means there is only one set of meta tags for the entire product browser. So it still doesn't really work. I can only get it to be correct for one product. the only correct part is that it links to the right product page.
  #9  
Old 07-30-2010, 02:33 PM
Qetzal's Avatar
Qetzal Qetzal is offline
Ecwid Team
 
Join Date: Sep 2009
Posts: 10,847
Default

Quote:
Originally Posted by The Cycle Shed View Post
If I put it in the header that means there is only one set of meta tags for the entire product browser. So it still doesn't really work. I can only get it to be correct for one product. the only correct part is that it links to the right product page.
Unfortunately, Facebook`s Like button cannot get meta tags which a set dynamically on a page. So, it will always get the same value for all pages.

However. a workaround exists. It's a bit tricky, but it should work.

1. Get the URL to your product page. Shorten it using bit.ly
2. Go to http://meyerweb.com/eric/tools/dencoder/
Insert your bitly link and press the "Encode" button.

3. Then get your Store ID and Product ID (you can get it from the product URL).

4. In this URL:

Code:
http://app.ecwid.com/fb-sharer?ownerid=STOREID&productid=PRODUCTID&url=ENCODED-BITLY-URL
replace STOREID, PRODUCTID and ENCODED-BITLY-URL with real values.

5. Use this URL to create your Like button: http://developers.facebook.com/docs/...e/plugins/like
__________________
Eugene K.
Ecwid Team

@ecwid | Facebook | Ecwid Knowledge Base

Last edited by qetzal; 07-30-2010 at 02:36 PM.
  #10  
Old 07-31-2010, 12:23 AM
The Cycle Shed's Avatar
The Cycle Shed The Cycle Shed is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Default

So can we expect a script to do this for us in the future. A checkbox in the CP that says generate Facebook like buttons. I think I'll submit an idea for a Promotion tab in the CP where this option to generate like button could be as well as cross selling and any other promotion integration that the store has/ can have.
Closed Thread
The information in this thread might be outdated
If the solution did not help, please, check our Help Portal or contact Ecwid Team.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:57 PM.
Powered by vBulletin® Version 3.8.11. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.