View Single Post
  #2  
Old 08-15-2013, 09:45 AM
Matt Ecwid's Avatar
Matt Ecwid Matt Ecwid is offline
Ecwid Team
 
Join Date: Oct 2011
Posts: 4,947
Default

Quote:
Originally Posted by Tri-Parish Web Mall View Post
so what's happening is the when i use the new recently released responsive code for ecwid it breaks my fixed menu in the sidebar-a position which is to the left of the article or store is located.

i'm using a rockettheme template in joomla

the page below (eia) works fine and does NOT use ecwid's responsive code that has been recently released. as you can see the sidebar-a position menu on the left of the store is correct and shows
http://go-smg.com/tpwm/index.php/stores/eia.html

the page below (truefind) IS using the responsive code recently released and the fixed menu in sidebar-a position on the left of the article is no longer appearing.
http://go-smg.com/tpwm/index.php/stores/true-find.html

all of my side bar modules are gone on the truefind storefront page. this happens only when i use the responsive code for ecwid as the eia page is still the non responsive and i did test this with other pages and only happens with the responsive code...please advise...i really need to get this figured out so i can continue with the necessary changes.

forum post: "Ecwid product browser widget breaks my fixed menu" - this forum post had similar issues except it was not addressing the responsive code aspect of mine. since my issue appears with the responsive they recommended creating a new post/topic.

thanks!

anyone????

i'm really at a loss as to how to fix this...
Hello,

I've inspected your site. As far as I can see, the issue unlikely has anything to do with responsive mode. It needs to be investigated anyway though.

As smoothsailingclothing mentioned in the related thread, you have different layouts on those page. In fact, those are also different Ecwid stores (they do not belong to the same Ecwid account).

Most likely, the closing </div> element is missing in the second integration.

Please describe how you integrated store widgets on those pages. As far as I can see, they weren't integrated using our Joomla plugin, rather were they placed using custom HTML modules. Is it so? Why? Anyway, can you please provide the exact integration code you use for the second page (where layout is broken). I will look into it. I think the reason is in the code. Thank you.
__________________
Matt K
Ecwid Team

Ecwid Guide for Beginners

Ecwid Help Center

Ecwid video tutorials
The Following User Says Thank You to Matt Ecwid For This Useful Post:
Tri-Parish Web Mall (08-15-2013)