View Single Post
  #14  
Old 04-10-2012, 05:40 PM
Steve Strickland1's Avatar
Steve Strickland1 Steve Strickland1 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 13
Default

Quote:
Originally Posted by Makfruit View Post
Thank you. I've inspected your site. As far as I can see, the javascript code you've added is corrupted by Wordpress editor you used to enter it.

Now the code looks as follows:
Code:
<script>
var confirmationPageURL = "http://google.com";</p>
<p>// Add handler for Ecwid's OnPageLoad event
if (
  typeof(Ecwid) == 'object'
  #038;#038; typeof(Ecwid.OnPageLoad) == 'object'
) {
  Ecwid.OnPageLoad.add(function(page) {
    // Redirect user if needed
    if (
      typeof(page) == 'object'
      #038;#038; 'ORDER_CONFIRMATION' == page.type
    ) {
      window.location = confirmationPageURL;
    }
  });
}
</script>
I've marked errors with red. Most likely, the text editor you used added those corrections. Please try to re-enter the code, using this instructions:
1) Toggle page/post editor in HTML mode (WYSIWYG mode doesn't allow javascript codes)
2) Enter the code
3) Save it (without returning to WYSIWYG mode).
Hi Makfruit,

Thanks for the help. I did update my page and have removed the information you mentioned. However, the redirect still does not work. I can complete an order successfully, but after that, nothing happens. You can submit orders if you want. It's in demo mode so nothing actually is charged (I just get email notifications). What else do you think could be causing it?

Thanks again,

Steve