View Single Post
  #11  
Old 07-23-2012, 08:15 PM
Sturtevants's Avatar
Sturtevants Sturtevants is offline
Junior Member
 
Join Date: Jun 2012
Posts: 16
Default

I can't seem to get this to work using either of these methods. Maybe I'm just missing something?

I want this page to open to this view without the other product tabs across the top.

I've tried the following but it didn't work:
Code:
<!-- Ecwid code. Please do not remove this line  otherwise your Ecwid shopping cart will not work properly. --> [ecwid_script] [ecwid_minicart] [ecwid_searchbox] [ecwid_categories] [ecwid_productbrowser] <!-- Ecwid code end -->
<div> <script type='text/javascript' src='http://app.ecwid.com/script.js?1273222'></script> <script type='text/javascript'>  xProductBrowser("categoriesPerRow=3","views=grid(3,3) list(10) table(20)","categoryView=grid","searchView=list","style=","defaultCategoryId=2924243"); </script> </div>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.js"></script>
<script type="text/javascript">// <![CDATA[
(function() {
  var __indexOf = [].indexOf || function(item) { for (var i = 0, l = this.length; i < l; i++) { if (i in this && this[i] === item) return i; } return -1; };
  var categories;

  /* if you need to have the zero price generally visible in the store and hide them only in some categories, you can put those categories' IDs, comma separated, into categories array below */
  categories = [924243];
  /* like
  categories = [2222333, 44455555];
  */

  Ecwid.OnAPILoaded.add(function() {
    var zeroval;
    zeroval = Ecwid.formatCurrency(0);
    Ecwid.OnPageLoaded.add(function(page) {
      var $, _ref;
      $ = window.jQuery;
      if (page.type === 'PRODUCT' 924243; ((_ref = page.categoryId, __indexOf.call(categories, _ref) >= 0) || categories.length === 0)) {
        $('div.ecwid-productBrowser-price:contains("'+zeroval+'")').css({
          display: 'none'
        });
      }
    });
  });
})();
// ]]></script>

I've been trying to get this to work for quite a while now. Any suggestions on what I'm doing wrong? Thanks!