View Single Post
  #5  
Old 01-12-2015, 11:08 AM
Clara K's Avatar
Clara K Clara K is offline
Ecwid Team
 
Join Date: Nov 2014
Posts: 655
Default

Hello,

Thanks a lot for your question!

I have checked your store and seen that the search works fine and the results are open in the same window, not in a pop-up (please see the screenshot: http://take.ms/bk3Ia).

I believe you have already fixed this, and please let me explain the solution for our other users who might face a similar issue and visit this thread.

The thing is that Ecwid always opens the search results in a pop-up window when there is no product browser on the page where the search widget is located.

In order to avoid this pop-up, you should use the "ecwid_ProductBrowserURL" option. With this option Ecwid works like this: when a visitor uses the "Search" box widget on a page with no product browser installed, they get redirected to a special page where the Product Browser is installed and Ecwid shows the search results on that page.

So you can just create a new page on your site and install a product browser there, so your customers will be redirected to that page for the search results.

To set "ecwid_ProductBrowserURL" option, you need to add the following JavaScript code to all the pages, where Ecwid widgets are installed:
Code:
 
<script> var ecwid_ProductBrowserURL = "PB_URL"; </script>
where PB_URL is the full URL of the page where your product browser is installed.

When this is done, the search results will be open on a separate page, not in a popup.
__________________
Clara
Ecwid Customer Care Team

Help Center


⬇ Please click Thanks if my reply helped you.