View Single Post
Old 01-03-2018, 09:59 AM
Stacy_P's Avatar
Stacy_P Stacy_P is offline
Ecwid Team
Join Date: Jan 2016
Posts: 308

Originally Posted by Christine Norris1 View Post
How can we help you? I see the button to verify my shop when added through Facebook, but when I click the link I see: Only page's owners can access page settings

When I try to add it through the Ecwid dashboard, it is not listed.

I have verified that I am the admin of the page. This is a brand new page and launch for our company. We are looking to using a premium account, but if we can not get this to work in trial mode. We will look elsewhere for another way to sell on Facebook.

Please provide the link to your storefront.

The trial is working on our Wordpress page:
Hello Christine,

this is Stacy from Ecwid Customer Care team.

I have an update for you!

First of all, I'm sorry you faced the issue. I'm here to help you with it.

I inspected your store and the link to your Facebook storefront as well. I could see this message on the page

It looks like you should just add the Store ID of your Ecwid account. As I can see, it is Store ID 5508028.

So, here is what you should do to fix it:

- Go to the settings page of your Ecwid app on Facebook, here is a direct link:
- Click on Settings link, like this:

- You will be redirected to the app settings. Specify your Store ID (5508028) here:

- scroll down the page and save the changes.

I really hope this helps.

Please, do let me know if it works for you. Thank you in advance!
Ecwid Customer Care Team
Help Center

⬇ Please click Thanks if my reply helped you.

Last edited by Stacy_P; 01-03-2018 at 10:05 AM.
The Following User Says Thank You to Stacy_P For This Useful Post: